Skip to content

← Actionable
Critical, CVSS 9.1amended

@xhmikosr/decompress: Path traversal via symlink chain

CVE-2026-101894GHSA-hrh2-vp3x-79xf

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @xhmikosr/decompress

    Affected
    >= 11.0.0, <= 11.1.3<= 10.2.1
    Fixed in
    11.1.4, 10.2.2
  • npm decompress

    Affected
    <= 4.2.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-101894: 0.81% estimated exploitation activity in the next 30 days; percentile 57.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When extracting an untrusted archive with the default decompress(input, output) API, a crafted archive containing a chain of symlink entries can make a later entry resolve outside the output directory. The lexical containment checks pass, but the kernel follows the planted symlinks to a path outside output, letting an attacker write (and read) files outside the intended extraction directory. Overwriting startup scripts or configuration can lead to remote code execution. This is a bypass of the hardening in GHSA-mp2f-45pm-3cg9. Any application that extracts attacker-controlled archives is affected. Patches Fixed in 11.1.4 (latest) and backported to 10.2.2 (release-v10 dist-tag). Upgrade to one of these. The unmaintained upstream decompress package shares this flaw and will not be patched. Migrate to @xhmikosr/decompress@11.1.4 (or @10.2.2). Workarounds None. Do not extract untrusted archives on affected versions. If you cannot upgrade, validate entries out of band and reject…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hrh2-vp3x-79xf

  2. Revision 2 · amended ·

    Amended from osv record GHSA-hrh2-vp3x-79xf

  3. Revision 1 · created ·

    Published from ghsa record GHSA-hrh2-vp3x-79xf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-101894

Advisory: @xhmikosr/decompress: Path traversal via symlink chain
IDs: CVE-2026-101894, GHSA-hrh2-vp3x-79xf
Record: https://patchnext.com/advisories/cve-2026-101894 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @xhmikosr/decompress 11.1.4, 10.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @xhmikosr/decompress: affected >= 11.0.0, <= 11.1.3; <= 10.2.1; fixed in 11.1.4, 10.2.2
- npm decompress: affected <= 4.2.1

## Suggested inspection (read-only)
- `npm ls @xhmikosr/decompress --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls decompress --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @xhmikosr/decompress, decompress.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hrh2-vp3x-79xf (GitHub-reviewed advisory GHSA-hrh2-vp3x-79xf lists affected ranges: npm @xhmikosr/decompress >=11.0.0 =0 =0 <=4.2.1)
- Verified: https://osv.dev/vulnerability/GHSA-hrh2-vp3x-79xf (OSV record GHSA-hrh2-vp3x-79xf lists affected ranges: npm @xhmikosr/decompress >=11.0.0 =0 =0 <=4.2.1)

Commands are suggestions: review each one before running it.

Loading voting…