Apache Tomcat: JNDIRealm bind credential validation fails open for non-GSSAPI SASL mechanisms
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tomcat 11.0.27, 10.1.61, 9.0.123), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami tomcat
- Affected
- >= 7.0.0, < 9.0.123>= 10.1.0, < 10.1.61>= 11.0.0, < 11.0.27
- Fixed in
- 10.1.61, 9.0.123, 11.0.27
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-tomcat-2026-101296 lists affected ranges: Bitnami tomcat >=7.0.0 =10.1.0 =11.0.0 <11.0.27 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2026-101296: 0.63% estimated exploitation activity in the next 30 days; percentile 50.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password. This issue affects Apache Tomcat: from 11.0.0 through 11.0.26, from 10.1.0 through 10.1.60, from 9.0.0 through 9.0.122. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record BIT-tomcat-2026-101296
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-101296 Advisory: Apache Tomcat: JNDIRealm bind credential validation fails open for non-GSSAPI SASL mechanisms IDs: CVE-2026-101296 Record: https://patchnext.com/advisories/cve-2026-101296 (revision 1, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tomcat 11.0.27, 10.1.61, 9.0.123. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami tomcat: affected >= 7.0.0, < 9.0.123; >= 10.1.0, < 10.1.61; >= 11.0.0, < 11.0.27; fixed in 10.1.61, 9.0.123, 11.0.27 ## Suggested inspection (read-only) - Bitnami tomcat: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/BIT-tomcat-2026-101296 (OSV record BIT-tomcat-2026-101296 lists affected ranges: Bitnami tomcat >=7.0.0 =10.1.0 =11.0.0 <11.0.27 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…