vm2: NodeVM custom resolution bypasses external path boundaries
CVE-2026-100721GHSA-5h3f-q97h-ccvc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- <= 3.12.1
- Fixed in
- 3.12.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5h3f-q97h-ccvc lists affected ranges: npm vm2 >=0 <=3.12.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5h3f-q97h-ccvc lists affected ranges: npm vm2 >=0 <3.12.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-100721: 0.59% estimated exploitation activity in the next 30 days; percentile 48.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary At source revision 91034466bfb7f56b95fd48083ec6ca36d058f164 of vm2 3.11.8, an untrusted NodeVM guest can turn one allowlisted custom-resolved module into authorization for a separate file whose path merely shares the resolved path's string prefix. LegacyResolver.customResolve stores the resolved path in this.externals as ^<path without an end or separator boundary; a later absolute require of a sibling such as foo2/index.js therefore passes the external check and is loaded through hostRequire when the configured context is host. The decisive attack loaded foo as FOOOK and then executed the prefix-sharing sibling, which returned PREFIXPWN after invoking childprocess; an otherwise identical control denied the sibling with ENOTFOUND. Technical Details The affected configuration is a documented NodeVM use in which the embedder sets require.external to {modules: ['foo'], transitive: false}, supplies a custom resolver that returns the foo directory, sets a root directory, and uses…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-5h3f-q97h-ccvc
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-5h3f-q97h-ccvc
- Revision 1 · created ·
Published from ghsa record GHSA-5h3f-q97h-ccvc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-100721 Advisory: vm2: NodeVM custom resolution bypasses external path boundaries IDs: CVE-2026-100721, GHSA-5h3f-q97h-ccvc Record: https://patchnext.com/advisories/cve-2026-100721 (revision 4, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected <= 3.12.1; fixed in 3.12.2 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5h3f-q97h-ccvc (GitHub-reviewed advisory GHSA-5h3f-q97h-ccvc lists affected ranges: npm vm2 >=0 <=3.12.1) - Verified: https://osv.dev/vulnerability/GHSA-5h3f-q97h-ccvc (OSV record GHSA-5h3f-q97h-ccvc lists affected ranges: npm vm2 >=0 <3.12.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…