Eclipse Jetty Digest Authentication: ISO-8859-1 lossy encoding allows authentication bypass via character substitution
CVE-2026-10050GHSA-2fvj-hgj9-j2gr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty.ee9:jetty-ee9-security 12.1.10, 12.0.36; org.eclipse.jetty:jetty-security 12.1.10, 12.0.36, 11.0.31, 10.0.31, 9.4.63; org.eclipse.jetty.ee8:jetty-ee8-security 12.1.10, 12.0.36), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.eclipse.jetty.ee9:jetty-ee9-security
- Affected
- >= 12.0.0, <= 12.0.35>= 12.1.0, <= 12.1.9
- Fixed in
- 12.0.36, 12.1.10
Maven org.eclipse.jetty:jetty-security
- Affected
- >= 9.4.0.v20161208, <= 9.4.58.v20250814>= 10.0.0, <= 10.0.26>= 11.0.0, <= 11.0.26>= 12.0.0, <= 12.0.35>= 12.1.0, <= 12.1.9
- Fixed in
- 11.0.31, 12.0.36, 12.1.10, 9.4.63, 10.0.31
Maven org.eclipse.jetty.ee8:jetty-ee8-security
- Affected
- >= 12.0.0, <= 12.0.35>= 12.1.0, <= 12.1.9
- Fixed in
- 12.0.36, 12.1.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2fvj-hgj9-j2gr lists affected ranges: Maven org.eclipse.jetty:jetty-security >=9.4.0.v20161208 =10.0.0 =11.0.0 =12.0.0 =12.1.0 =12.0.0 =12.1.0 =12.0.0 =12.1.0 <=12.1.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-10050: 0.63% estimated exploitation activity in the next 30 days; percentile 50.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The DigestAuthentication.apply() method in Jetty's HTTP client uses getBytes(StandardCharsets.ISO88591) at three locations (lines 171, 179, 196) to compute Digest auth response hashes. ISO-8859-1 silently replaces any character above U+00FF (Chinese, Japanese, Cyrillic, Arabic, Emoji, etc.) with 0x3F (?), causing all such characters to produce identical hash contributions. An attacker who knows a victim's username can bypass Digest authentication by replacing all non-Latin-1 characters in the password with ? characters, since the collision password produces the same MD5-based Digest response hash as the original password. Details Root Cause In jetty-core/jetty-client/src/main/java/org/eclipse/jetty/client/DigestAuthentication.java, the apply() method computes the three Digest auth hashes (H(A1), H(A2), and the final response) using ISO-8859-1 character encoding: ISO-8859-1 (Latin-1) can only encode characters in the range U+0000–U+00FF. Any character outside this range —…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2fvj-hgj9-j2gr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-10050 Advisory: Eclipse Jetty Digest Authentication: ISO-8859-1 lossy encoding allows authentication bypass via character substitution IDs: CVE-2026-10050, GHSA-2fvj-hgj9-j2gr Record: https://patchnext.com/advisories/cve-2026-10050 (revision 1, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty.ee9:jetty-ee9-security 12.1.10, 12.0.36; org.eclipse.jetty:jetty-security 12.1.10, 12.0.36, 11.0.31, 10.0.31, 9.4.63; org.eclipse.jetty.ee8:jetty-ee8-security 12.1.10, 12.0.36. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.eclipse.jetty.ee9:jetty-ee9-security: affected >= 12.0.0, <= 12.0.35; >= 12.1.0, <= 12.1.9; fixed in 12.0.36, 12.1.10 - Maven org.eclipse.jetty:jetty-security: affected >= 9.4.0.v20161208, <= 9.4.58.v20250814; >= 10.0.0, <= 10.0.26; >= 11.0.0, <= 11.0.26; >= 12.0.0, <= 12.0.35; >= 12.1.0, <= 12.1.9; fixed in 11.0.31, 12.0.36, 12.1.10, 9.4.63, 10.0.31 - Maven org.eclipse.jetty.ee8:jetty-ee8-security: affected >= 12.0.0, <= 12.0.35; >= 12.1.0, <= 12.1.9; fixed in 12.0.36, 12.1.10 ## Suggested inspection (read-only) - Maven org.eclipse.jetty.ee9:jetty-ee9-security: check the installed version with your package manager. - Maven org.eclipse.jetty:jetty-security: check the installed version with your package manager. - Maven org.eclipse.jetty.ee8:jetty-ee8-security: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.eclipse.jetty.ee9:jetty-ee9-security, org.eclipse.jetty:jetty-security, org.eclipse.jetty.ee8:jetty-ee8-security. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2fvj-hgj9-j2gr (GitHub-reviewed advisory GHSA-2fvj-hgj9-j2gr lists affected ranges: Maven org.eclipse.jetty:jetty-security >=9.4.0.v20161208 =10.0.0 =11.0.0 =12.0.0 =12.1.0 =12.0.0 =12.1.0 =12.0.0 =12.1.0 <=12.1.9) Commands are suggestions: review each one before running it.
Loading voting…