Skip to content

← Actionable
High, CVSS 7.5amended

OpenNext Cloudflare: Cache interception can bypass middleware protection for encoded paths

CVE-2026-100409GHSA-2vc4-c4r6-p6v6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@opennextjs/cloudflare 1.20.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-100409: 0.49% estimated exploitation activity in the next 30 days; percentile 42.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When cache interception is enabled, @opennextjs/cloudflare can interpret percent-encoded paths differently during middleware matching and cache lookup. An encoded request may fail to match authorization middleware, then be decoded into the cache key of a protected route. The cached response may consequently be returned without invoking the middleware. enableCacheInterception is disabled by default. Impact A remote unauthenticated attacker may retrieve cached content from routes intended to be protected by middleware. An application is affected when it: - explicitly enables enableCacheInterception; - relies on middleware for access control; and - has a matching cached route. Details Middleware matching previously used the encoded request pathname, while cache interception decoded the pathname before selecting a cache entry. For example, consider an application with: - middleware matcher /admin/:path; - middleware returning 401 Authentication required for /admin; - a statically…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2vc4-c4r6-p6v6

  2. Revision 2 · amended ·

    Amended from osv record GHSA-2vc4-c4r6-p6v6

  3. Revision 1 · created ·

    Published from ghsa record GHSA-2vc4-c4r6-p6v6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-100409

Advisory: OpenNext Cloudflare: Cache interception can bypass middleware protection for encoded paths
IDs: CVE-2026-100409, GHSA-2vc4-c4r6-p6v6
Record: https://patchnext.com/advisories/cve-2026-100409 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @opennextjs/cloudflare 1.20.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @opennextjs/cloudflare: affected >= 0.3.0, < 1.20.2; fixed in 1.20.2

## Suggested inspection (read-only)
- `npm ls @opennextjs/cloudflare --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @opennextjs/cloudflare.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2vc4-c4r6-p6v6 (GitHub-reviewed advisory GHSA-2vc4-c4r6-p6v6 lists affected ranges: npm @opennextjs/cloudflare >=0.3.0 <1.20.2)
- Verified: https://osv.dev/vulnerability/GHSA-2vc4-c4r6-p6v6 (OSV record GHSA-2vc4-c4r6-p6v6 lists affected ranges: npm @opennextjs/cloudflare >=0.3.0 <1.20.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…