CliInvoke: Argument Injection in Extensibility Runner Factory
CVE-2026-100369GHSA-j73w-8hfr-4gc9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (alastairlundy.cliinvoke 2.0.2; cliinvoke 3.0.0-beta.2, 2.10.5, 2.9.4, 2.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet alastairlundy.cliinvoke
- Affected
- >= 2.0.0-alpha.1, <= 2.0.0
- Fixed in
- 2.0.2
NuGet cliinvoke
- Affected
- >= 2.0.0, <= 2.8.4>= 2.9.0, <= 2.9.3>= 2.10.0, <= 2.10.4>= 3.0.0-alpha.1, <= 3.0.0-beta.1
- Fixed in
- 3.0.0-beta.2, 2.9.4, 2.10.5, 2.8.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j73w-8hfr-4gc9 lists affected ranges: NuGet cliinvoke >=2.0.0 =2.9.0 =2.10.0 =3.0.0-alpha.1 =2.0.0-alpha.1 <2.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j73w-8hfr-4gc9 lists affected ranges: NuGet cliinvoke >=2.0.0 =2.9.0 =2.10.0 =3.0.0-alpha.1 =2.0.0-alpha.1 <=2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-100369: 0.36% estimated exploitation activity in the next 30 days; percentile 29.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An argument-injection vulnerability exists in the CliInvoke package's runner factory: RunnerProcessFactory on the 2.x line and RunnerConfigurationFactory on the 3.x line. The factory joins the runner arguments, the caller's target, and the caller's arguments into a single ProcessStartInfo.Arguments string and hands it to the OS. The OS command-line parser re-tokenizes the string before the runner sees it. A double quote (") in the target or in any argument closes the OS-level quoted region and lets the next character enter argv as a separate element. Patches Upgrade to: - 2.8.5 (2.8.x line) - 2.9.4 (2.9.x line) - 2.10.5 (2.10.x line) - 3.0.0-beta.2 (3.x pre-release line) Workarounds No complete workaround is available. Until you can upgrade: - Strip " from any target or argument before passing it to the factory. On shell runners, also strip ;, |, &, $, backtick, and parentheses. - Or bypass the factory entirely and build the ProcessConfiguration directly. Set ArgumentList…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-j73w-8hfr-4gc9
- Revision 1 · created ·
Published from osv record GHSA-j73w-8hfr-4gc9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-100369 Advisory: CliInvoke: Argument Injection in Extensibility Runner Factory IDs: CVE-2026-100369, GHSA-j73w-8hfr-4gc9 Record: https://patchnext.com/advisories/cve-2026-100369 (revision 2, source checked 26 Oct 2026, 17:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: alastairlundy.cliinvoke 2.0.2; cliinvoke 3.0.0-beta.2, 2.10.5, 2.9.4, 2.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet alastairlundy.cliinvoke: affected >= 2.0.0-alpha.1, <= 2.0.0; fixed in 2.0.2 - NuGet cliinvoke: affected >= 2.0.0, <= 2.8.4; >= 2.9.0, <= 2.9.3; >= 2.10.0, <= 2.10.4; >= 3.0.0-alpha.1, <= 3.0.0-beta.1; fixed in 3.0.0-beta.2, 2.9.4, 2.10.5, 2.8.5 ## Suggested inspection (read-only) - NuGet alastairlundy.cliinvoke: check the installed version with your package manager. - NuGet cliinvoke: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on alastairlundy.cliinvoke, cliinvoke. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j73w-8hfr-4gc9 (OSV record GHSA-j73w-8hfr-4gc9 lists affected ranges: NuGet cliinvoke >=2.0.0 =2.9.0 =2.10.0 =3.0.0-alpha.1 =2.0.0-alpha.1 <2.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-j73w-8hfr-4gc9 (GitHub-reviewed advisory GHSA-j73w-8hfr-4gc9 lists affected ranges: NuGet cliinvoke >=2.0.0 =2.9.0 =2.10.0 =3.0.0-alpha.1 =2.0.0-alpha.1 <=2.0.0) Commands are suggestions: review each one before running it.
Loading voting…