Skip to content

← Actionable
High, CVSS 7.5amended

kin-openapi: Incomplete Fix for GHSA-p6wj-qrr4-pgh5: Three Unpatched nil-Items Panic Paths in openapi3filter

CVE-2026-100353GHSA-vrcc-3ch7-hppw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/getkin/kin-openapi 0.149.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-100353: 0.34% estimated exploitation activity in the next 30 days; percentile 26.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The fix for GHSA-p6wj-qrr4-pgh5 addressed a nil-pointer dereference that occurs when an OpenAPI 3.1 array schema omits the items keyword (which is legal under JSON Schema 2020-12). That fix patched three decoder paths: the standalone parseArray function, the top-level array check in UrlencodedBodyDecoder, and MultipartBodyDecoder. Three additional crash paths were missed. All of them reach the unguarded urlValuesDecoder.parseArray method (openapi3filter/reqrespdecoder.go:576) or the unguarded array branch in buildResObj (line 1015): 1. Query parameters with type: array and no items. 2. deepObject query parameters containing an array property with no items. 3. URL-encoded request bodies where the array lives inside an allOf / anyOf / oneOf sub-schema. This path bypasses the guard added by the GHSA-p6wj-qrr4-pgh5 fix, because that guard only inspects top-level properties. Each path is triggerable by an unauthenticated client and produces a deterministic nil-pointer panic during…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vrcc-3ch7-hppw

  2. Revision 1 · created ·

    Published from osv record GHSA-vrcc-3ch7-hppw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-100353

Advisory: kin-openapi: Incomplete Fix for GHSA-p6wj-qrr4-pgh5: Three Unpatched nil-Items Panic Paths in openapi3filter
IDs: CVE-2026-100353, GHSA-vrcc-3ch7-hppw
Record: https://patchnext.com/advisories/cve-2026-100353 (revision 2, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/getkin/kin-openapi 0.149.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/getkin/kin-openapi: affected >= 0.136.0, < 0.149.0; fixed in 0.149.0

## Suggested inspection (read-only)
- Go github.com/getkin/kin-openapi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/getkin/kin-openapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vrcc-3ch7-hppw (OSV record GHSA-vrcc-3ch7-hppw lists affected ranges: Go github.com/getkin/kin-openapi >=0.136.0 <0.149.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vrcc-3ch7-hppw (GitHub-reviewed advisory GHSA-vrcc-3ch7-hppw lists affected ranges: Go github.com/getkin/kin-openapi >=0.136.0 <0.149.0)

Commands are suggestions: review each one before running it.

Loading voting…