Skip to content

← Actionable
Medium, CVSS 5.3amended

kin-openapi: Unauthenticated panic (DoS) in openapi3filter legacy router via non-canonical/unsupported HTTP method on a static path

CVE-2026-100347GHSA-fh4f-47mf-f2gj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/getkin/kin-openapi 0.145.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-100347: 0.52% estimated exploitation activity in the next 30 days; percentile 43.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The openapi3filter.ValidationHandler (the exported, documented request-validation middleware) hard-wires the legacy router (routers/legacy). That router matches the incoming request method verbatim against a trie built exclusively from upper-cased canonical HTTP methods. A request carrying a method token that is not one of the 9 standard methods — a legitimate-but-unsupported token such as PROPFIND, or a non-canonical case variant such as lowercase get — misses the trie, leaves route == nil, and for an existing static path falls through to PathItem.GetOperation(method), whose default: case calls panic(...). The panic fires inside route resolution, before any authentication runs. This is an unauthenticated, remotely triggerable denial of service (recovered per-connection panic + unbounded error-log growth). Root Cause - openapi3filter/validationhandler.go:39 — ValidationHandler.Load() always constructs legacyrouter.NewRouter(doc); there is no alternative router option on this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fh4f-47mf-f2gj

  2. Revision 1 · created ·

    Published from osv record GHSA-fh4f-47mf-f2gj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-100347

Advisory: kin-openapi: Unauthenticated panic (DoS) in openapi3filter legacy router via non-canonical/unsupported HTTP method on a static path
IDs: CVE-2026-100347, GHSA-fh4f-47mf-f2gj
Record: https://patchnext.com/advisories/cve-2026-100347 (revision 2, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/getkin/kin-openapi 0.145.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/getkin/kin-openapi: affected <= 0.144.0; fixed in 0.145.0

## Suggested inspection (read-only)
- Go github.com/getkin/kin-openapi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/getkin/kin-openapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fh4f-47mf-f2gj (OSV record GHSA-fh4f-47mf-f2gj lists affected ranges: Go github.com/getkin/kin-openapi >=0 <0.145.0 (fixed))
- Verified: https://github.com/advisories/GHSA-fh4f-47mf-f2gj (GitHub-reviewed advisory GHSA-fh4f-47mf-f2gj lists affected ranges: Go github.com/getkin/kin-openapi >=0 <=0.144.0)

Commands are suggestions: review each one before running it.

Loading voting…