Skip to content

← Actionable
High, CVSS 7.7amended

Wrangler affected by OS Command Injection in wrangler pages deploy

CVE-2026-0933GHSA-36p8-mvp6-cv38

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wrangler 4.59.1, 3.114.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm wrangler

    Affected
    >= 2.0.15, < 3.114.17>= 4.0.0, < 4.59.1
    Fixed in
    3.114.17, 4.59.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-0933: 1.51% estimated exploitation activity in the next 30 days; percentile 74.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A command injection vulnerability (CWE-78) has been found to exist in the wrangler pages deploy command. The issue occurs because the --commit-hash parameter is passed directly to a shell command without proper validation or sanitization, allowing an attacker with control of --commit-hash to execute arbitrary commands on the system running Wrangler. Root cause The commitHash variable, derived from user input via the --commit-hash CLI argument, is interpolated directly into a shell command using template literals (e.g., execSync(git show -s --format=%B ${commitHash})). Shell metacharacters are interpreted by the shell, enabling command execution. Impact This vulnerability is generally hard to exploit, as it requires --commit-hash to be attacker controlled. The vulnerability primarily affects CI/CD environments where wrangler pages deploy is used in automated pipelines and the --commit-hash parameter is populated from external, potentially untrusted sources. An attacker could…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-36p8-mvp6-cv38

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-36p8-mvp6-cv38

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-0933

Advisory: Wrangler affected by OS Command Injection in `wrangler pages deploy`
IDs: CVE-2026-0933, GHSA-36p8-mvp6-cv38
Record: https://patchnext.com/advisories/cve-2026-0933 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wrangler 4.59.1, 3.114.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm wrangler: affected >= 2.0.15, < 3.114.17; >= 4.0.0, < 4.59.1; fixed in 3.114.17, 4.59.1

## Suggested inspection (read-only)
- `npm ls wrangler --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wrangler.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-36p8-mvp6-cv38 (OSV record GHSA-36p8-mvp6-cv38 lists affected ranges: npm wrangler >=2.0.15 =4.0.0 <4.59.1 (fixed))
- Verified: https://github.com/advisories/GHSA-36p8-mvp6-cv38 (GitHub-reviewed advisory GHSA-36p8-mvp6-cv38 lists affected ranges: npm wrangler >=2.0.15 =4.0.0 <4.59.1)

Commands are suggestions: review each one before running it.

Loading voting…