Skip to content

← Actionable
High, CVSS 8.6amended

NLTK has a Path Traversal issue

CVE-2026-0847GHSA-68j8-pq59-fqgm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nltk 3.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nltk

    Affected
    < 3.9.3
    Fixed in
    3.9.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2026-0847: 1.00% estimated exploitation activity in the next 30 days; percentile 62.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability in NLTK versions up to and including 3.9.2 allows arbitrary file read via path traversal in multiple CorpusReader classes, including WordListCorpusReader, TaggedCorpusReader, and BracketParseCorpusReader. These classes fail to properly sanitize or validate file paths, enabling attackers to traverse directories and access sensitive files on the server. This issue is particularly critical in scenarios where user-controlled file inputs are processed, such as in machine learning APIs, chatbots, or NLP pipelines. Exploitation of this vulnerability can lead to unauthorized access to sensitive files, including system files, SSH private keys, and API tokens, and may potentially escalate to remote code execution when combined with other vulnerabilities.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-68j8-pq59-fqgm

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-68j8-pq59-fqgm

  3. Revision 2 · amended ·

    Amended from ghsa record GHSA-68j8-pq59-fqgm

  4. Revision 1 · created ·

    Published from osv record GHSA-68j8-pq59-fqgm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-0847

Advisory: NLTK has a Path Traversal issue
IDs: CVE-2026-0847, GHSA-68j8-pq59-fqgm
Record: https://patchnext.com/advisories/cve-2026-0847 (revision 4, source checked 4 Nov 2026, 06:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nltk 3.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nltk: affected < 3.9.3; fixed in 3.9.3

## Suggested inspection (read-only)
- `python -m pip show nltk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nltk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-68j8-pq59-fqgm (OSV record GHSA-68j8-pq59-fqgm lists affected ranges: PyPI nltk >=0 <=3.9.2)
- Verified: https://github.com/advisories/GHSA-68j8-pq59-fqgm (GitHub-reviewed advisory GHSA-68j8-pq59-fqgm lists affected ranges: PyPI nltk >=0 <=3.9.2)
- Verified: https://osv.dev/vulnerability/GHSA-68j8-pq59-fqgm (OSV record GHSA-68j8-pq59-fqgm lists affected ranges: PyPI nltk >=0 <3.9.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…