QuestDB UI's Web Console is Vulnerable to Cross-Site Scripting
CVE-2026-0824GHSA-xf94-h87h-g9wr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@questdb/web-console 1.1.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.1.10
- Fixed in
- 1.1.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xf94-h87h-g9wr lists affected ranges: npm @questdb/web-console >=0 <1.1.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xf94-h87h-g9wr lists affected ranges: npm @questdb/web-console >=0 <1.1.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-0824: 0.29% estimated exploitation activity in the next 30 days; percentile 21.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A security flaw has been discovered in questdb ui up to 1.11.9. Impacted is an unknown function of the component Web Console. The manipulation results in cross site scripting. The attack can be executed remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 1.1.10 is recommended to address this issue. The patch is identified as b42fd9f18476d844ae181a10a249e003dafb823d. You should upgrade the affected component. The vendor confirmed early that the fix "is going to be released as a part of QuestDB 9.3.0" as well.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xf94-h87h-g9wr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xf94-h87h-g9wr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-0824 Advisory: QuestDB UI's Web Console is Vulnerable to Cross-Site Scripting IDs: CVE-2026-0824, GHSA-xf94-h87h-g9wr Record: https://patchnext.com/advisories/cve-2026-0824 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @questdb/web-console 1.1.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @questdb/web-console: affected < 1.1.10; fixed in 1.1.10 ## Suggested inspection (read-only) - `npm ls @questdb/web-console --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @questdb/web-console. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xf94-h87h-g9wr (OSV record GHSA-xf94-h87h-g9wr lists affected ranges: npm @questdb/web-console >=0 <1.1.10 (fixed)) - Verified: https://github.com/advisories/GHSA-xf94-h87h-g9wr (GitHub-reviewed advisory GHSA-xf94-h87h-g9wr lists affected ranges: npm @questdb/web-console >=0 <1.1.10) Commands are suggestions: review each one before running it.
Loading voting…