Skip to content

← Actionable
Critical, CVSS 9.8amended

gemini-mcp-tool vulnerable to OS command injection and @file exfiltration via prompt quoting (CVE-2026-0755)

CVE-2026-0755GHSA-4h5r-5jm8-jxjm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gemini-mcp-tool 1.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-0755: 3.42% estimated exploitation activity in the next 30 days; percentile 88.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Untrusted prompt input could reach the Gemini CLI @file parser, allowing read/exfiltration of arbitrary local files (@/etc/passwd, @~/.ssh/idrsa, @../../secret). On Windows, unquoted cmd.exe metacharacters could break out into OS command injection. Fix (1.1.6): removed the broken shell:false double-quote wrapping; added assertSafeFileReferences() to contain @file refs to the working directory; hardened Windows cmd.exe argument quoting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4h5r-5jm8-jxjm

  2. Revision 2 · amended ·

    Amended from osv record GHSA-4h5r-5jm8-jxjm

  3. Revision 1 · created ·

    Published from ghsa record GHSA-4h5r-5jm8-jxjm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-0755

Advisory: gemini-mcp-tool vulnerable to OS command injection and @file exfiltration via prompt quoting (CVE-2026-0755)
IDs: CVE-2026-0755, GHSA-4h5r-5jm8-jxjm
Record: https://patchnext.com/advisories/cve-2026-0755 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gemini-mcp-tool 1.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm gemini-mcp-tool: affected >= 1.1.2, < 1.1.6; fixed in 1.1.6

## Suggested inspection (read-only)
- `npm ls gemini-mcp-tool --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gemini-mcp-tool.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4h5r-5jm8-jxjm (GitHub-reviewed advisory GHSA-4h5r-5jm8-jxjm lists affected ranges: npm gemini-mcp-tool >=1.1.2 <1.1.6)
- Verified: https://osv.dev/vulnerability/GHSA-4h5r-5jm8-jxjm (OSV record GHSA-4h5r-5jm8-jxjm lists affected ranges: npm gemini-mcp-tool >=1.1.2 <1.1.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…