Bouncy Castle has an LDAP injection
CVE-2026-0636GHSA-c3fc-8qff-9hwx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bouncycastle:bcprov-jdk14 1.84, 1.81.1, 1.80.2; org.bouncycastle:bcprov-jdk15to18 1.84, 1.81.1, 1.80.2; org.bouncycastle:bcprov-jdk18on 1.84, 1.81.1, 1.80.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.bouncycastle:bcprov-jdk14
- Affected
- >= 1.74, < 1.80.2>= 1.81, < 1.81.1>= 1.82, < 1.84
- Fixed in
- 1.81.1, 1.84, 1.80.2
Maven org.bouncycastle:bcprov-jdk15to18
- Affected
- >= 1.74, < 1.80.2>= 1.81, < 1.81.1>= 1.82, < 1.84
- Fixed in
- 1.81.1, 1.84, 1.80.2
Maven org.bouncycastle:bcprov-jdk18on
- Affected
- >= 1.74, < 1.80.2>= 1.81, < 1.81.1>= 1.82, < 1.84
- Fixed in
- 1.81.1, 1.84, 1.80.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c3fc-8qff-9hwx lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=1.74 =1.74 =1.74 <1.84
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c3fc-8qff-9hwx lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=1.74 =1.81 =1.82 =1.74 =1.81 =1.82 =1.74 =1.81 =1.82 <1.84
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c3fc-8qff-9hwx lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=1.74 =1.81 =1.82 =1.74 =1.81 =1.82 =1.74 =1.81 =1.82 <1.84 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P/RE:M/U:Amber · score source
- EPSS
- CVE-2026-0636: 0.53% estimated exploitation activity in the next 30 days; percentile 44.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper neutralization of special elements used in an LDAP query ('LDAP injection') vulnerability in Legion of the Bouncy Castle Inc. BC-JAVA bcprov on all (prov modules). This vulnerability is associated with program files LDAPStoreHelper. Issue affecting: BC 1.74 to 1.80.1, BC 1.81, BC 1.82 to BC 1.83. Fixed versions: BC 1.80.2, BC 1.81.1, BC 1.84
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-c3fc-8qff-9hwx
- Revision 2 · amended ·
Amended from ghsa record GHSA-c3fc-8qff-9hwx
- Revision 1 · created ·
Published from ghsa record GHSA-c3fc-8qff-9hwx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-0636 Advisory: Bouncy Castle has an LDAP injection IDs: CVE-2026-0636, GHSA-c3fc-8qff-9hwx Record: https://patchnext.com/advisories/cve-2026-0636 (revision 3, source checked 4 Nov 2026, 06:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.bouncycastle:bcprov-jdk14 1.84, 1.81.1, 1.80.2; org.bouncycastle:bcprov-jdk15to18 1.84, 1.81.1, 1.80.2; org.bouncycastle:bcprov-jdk18on 1.84, 1.81.1, 1.80.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.bouncycastle:bcprov-jdk14: affected >= 1.74, < 1.80.2; >= 1.81, < 1.81.1; >= 1.82, < 1.84; fixed in 1.81.1, 1.84, 1.80.2 - Maven org.bouncycastle:bcprov-jdk15to18: affected >= 1.74, < 1.80.2; >= 1.81, < 1.81.1; >= 1.82, < 1.84; fixed in 1.81.1, 1.84, 1.80.2 - Maven org.bouncycastle:bcprov-jdk18on: affected >= 1.74, < 1.80.2; >= 1.81, < 1.81.1; >= 1.82, < 1.84; fixed in 1.81.1, 1.84, 1.80.2 ## Suggested inspection (read-only) - Maven org.bouncycastle:bcprov-jdk14: check the installed version with your package manager. - Maven org.bouncycastle:bcprov-jdk15to18: check the installed version with your package manager. - Maven org.bouncycastle:bcprov-jdk18on: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.bouncycastle:bcprov-jdk14, org.bouncycastle:bcprov-jdk15to18, org.bouncycastle:bcprov-jdk18on. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c3fc-8qff-9hwx (GitHub-reviewed advisory GHSA-c3fc-8qff-9hwx lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=1.74 =1.74 =1.74 <1.84) - Verified: https://github.com/advisories/GHSA-c3fc-8qff-9hwx (GitHub-reviewed advisory GHSA-c3fc-8qff-9hwx lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=1.74 =1.81 =1.82 =1.74 =1.81 =1.82 =1.74 =1.81 =1.82 <1.84) - Verified: https://osv.dev/vulnerability/GHSA-c3fc-8qff-9hwx (OSV record GHSA-c3fc-8qff-9hwx lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=1.74 =1.81 =1.82 =1.74 =1.81 =1.82 =1.74 =1.81 =1.82 <1.84 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…