Skip to content

← Actionable
Medium, CVSS 6.5

Metricbeat affected by multiple denial of service vulnerabilities

CVE-2026-0528GHSA-w2gr-585j-r428

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/elastic/beats/v7 9.2.4, 9.1.10, 8.19.10, 7.0.0-alpha2.0.20251217054608-6e42552a23ce), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/elastic/beats/v7

    Affected
    < 7.0.0-alpha2.0.20251217054608-6e42552a23ce>= 8.0.0, < 8.19.10>= 9.0.0, < 9.1.10>= 9.2.0, < 9.2.4
    Fixed in
    8.19.10, 9.1.10, 7.0.0-alpha2.0.20251217054608-6e42552a23ce, 9.2.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-0528: 0.43% estimated exploitation activity in the next 30 days; percentile 36.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper Validation of Array Index (CWE-129) exists in Metricbeat can allow an attacker to cause a Denial of Service through Input Data Manipulation (CAPEC-153) via specially crafted, malformed payloads sent to the Graphite server metricset or Zookeeper server metricset. Additionally, Improper Input Validation (CWE-20) exists in the Prometheus helper module that can allow an attacker to cause a Denial of Service through Input Data Manipulation (CAPEC-153) via specially crafted, malformed metric data.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w2gr-585j-r428

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-0528

Advisory: Metricbeat affected by multiple denial of service vulnerabilities
IDs: CVE-2026-0528, GHSA-w2gr-585j-r428
Record: https://patchnext.com/advisories/cve-2026-0528 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/elastic/beats/v7 9.2.4, 9.1.10, 8.19.10, 7.0.0-alpha2.0.20251217054608-6e42552a23ce. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/elastic/beats/v7: affected < 7.0.0-alpha2.0.20251217054608-6e42552a23ce; >= 8.0.0, < 8.19.10; >= 9.0.0, < 9.1.10; >= 9.2.0, < 9.2.4; fixed in 8.19.10, 9.1.10, 7.0.0-alpha2.0.20251217054608-6e42552a23ce, 9.2.4

## Suggested inspection (read-only)
- Go github.com/elastic/beats/v7: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/elastic/beats/v7.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w2gr-585j-r428 (GitHub-reviewed advisory GHSA-w2gr-585j-r428 lists affected ranges: Go github.com/elastic/beats/v7 >=0 =8.0.0 =9.0.0 =9.2.0 <9.2.4)

Commands are suggestions: review each one before running it.

Loading voting…