jsondiffpatch is vulnerable to Cross-site Scripting (XSS) via HtmlFormatter::nodeBegin
CVE-2025-9910GHSA-33vc-wfww-vjfv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsondiffpatch 0.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm jsondiffpatch
- Affected
- < 0.7.2
- Fixed in
- 0.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-33vc-wfww-vjfv lists affected ranges: npm jsondiffpatch >=0 <0.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-33vc-wfww-vjfv lists affected ranges: npm jsondiffpatch >=0 <0.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-9910: 0.32% estimated exploitation activity in the next 30 days; percentile 24.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability in jsondiffpatch Versions of jsondiffpatch prior to 0.7.2 are vulnerable to Cross-site Scripting (XSS) in the HtmlFormatter (HtmlFormatter::nodeBegin). When diffs are rendered to HTML using the built-in formatter, untrusted payloads can inject scripts and execute in the context of a consuming web page. Affected versions: = 0, < 0.7.2 Patched version: 0.7.2 Remediation Upgrade to jsondiffpatch 0.7.2 or later. The fix hardens the HTML formatter to avoid script injection. Workarounds Avoid using the HTML formatter on untrusted diffs, or sanitize/escape the rendered output.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-33vc-wfww-vjfv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-33vc-wfww-vjfv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-9910 Advisory: jsondiffpatch is vulnerable to Cross-site Scripting (XSS) via HtmlFormatter::nodeBegin IDs: CVE-2025-9910, GHSA-33vc-wfww-vjfv Record: https://patchnext.com/advisories/cve-2025-9910 (revision 3, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jsondiffpatch 0.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm jsondiffpatch: affected < 0.7.2; fixed in 0.7.2 ## Suggested inspection (read-only) - `npm ls jsondiffpatch --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jsondiffpatch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-33vc-wfww-vjfv (OSV record GHSA-33vc-wfww-vjfv lists affected ranges: npm jsondiffpatch >=0 <0.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-33vc-wfww-vjfv (GitHub-reviewed advisory GHSA-33vc-wfww-vjfv lists affected ranges: npm jsondiffpatch >=0 <0.7.2) Commands are suggestions: review each one before running it.
Loading voting…