Mautic Vulnerable to User Enumeration via Response Timing
CVE-2025-9824GHSA-3ggv-qwcp-j6xg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 6.0.5, 5.2.8, 4.4.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mautic/core
- Affected
- >= 4.4.0, < 4.4.17>= 5.0.0-alpha, < 5.2.8>= 6.0.0-alpha, < 6.0.5
- Fixed in
- 5.2.8, 4.4.17, 6.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3ggv-qwcp-j6xg lists affected ranges: Packagist mautic/core >=4.4.0 =5.0.0-alpha =6.0.0-alpha <6.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-9824: 0.28% estimated exploitation activity in the next 30 days; percentile 20.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The attacker can validate if a user exists by checking the time login returns. This timing difference can be used to enumerate valid usernames, after which an attacker could attempt brute force attacks. Patches This vulnerability has been patched, implementing a timing-safe form login authenticator that ensures consistent response times regardless of whether a user exists or not. Technical Details The vulnerability was caused by different response times when: - A valid username was provided (password hashing occurred) - An invalid username was provided (no password hashing occurred) The fix introduces a TimingSafeFormLoginAuthenticator that performs a dummy password hash verification even for non-existent users, ensuring consistent timing. Workarounds No workarounds are available. Users should upgrade to the patched version. References -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3ggv-qwcp-j6xg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-9824 Advisory: Mautic Vulnerable to User Enumeration via Response Timing IDs: CVE-2025-9824, GHSA-3ggv-qwcp-j6xg Record: https://patchnext.com/advisories/cve-2025-9824 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mautic/core 6.0.5, 5.2.8, 4.4.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mautic/core: affected >= 4.4.0, < 4.4.17; >= 5.0.0-alpha, < 5.2.8; >= 6.0.0-alpha, < 6.0.5; fixed in 5.2.8, 4.4.17, 6.0.5 ## Suggested inspection (read-only) - Packagist mautic/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mautic/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3ggv-qwcp-j6xg (GitHub-reviewed advisory GHSA-3ggv-qwcp-j6xg lists affected ranges: Packagist mautic/core >=4.4.0 =5.0.0-alpha =6.0.0-alpha <6.0.5) Commands are suggestions: review each one before running it.
Loading voting…