Skip to content

← Actionable
Medium, CVSS 4.8

Mautic vulnerable to reflected XSS in lead:addLeadTags - Quick Add

CVE-2025-9823GHSA-9v8p-m85m-f7mm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 6.0.5, 5.2.8, 4.4.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core

    Affected
    >= 4.4.0, < 4.4.17>= 5.0.0-alpha, < 5.2.8>= 6.0.0-alpha, < 6.0.5
    Fixed in
    5.2.8, 4.4.17, 6.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-9823: 0.32% estimated exploitation activity in the next 30 days; percentile 24.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Cross-Site Scripting (XSS) vulnerability allows an attacker to execute arbitrary JavaScript in the context of another user’s session. This occurs because user-supplied input is reflected back in the server’s response without proper sanitization or escaping, potentially enabling malicious actions such as session hijacking, credential theft, or unauthorized actions in the application. Details The vulnerability resides in the “Tags” input field on the /s/ajax?action=lead:addLeadTags endpoint. Although the server applies sanitization before storing the data or returning it later, the payload is executed immediately in the victim’s browser upon reflection, allowing an attacker to run arbitrary JavaScript in the user’s session. Impact A Reflected XSS attack can have a significant impact, allowing attackers to steal sensitive user data like cookies, redirect users to malicious websites, manipulate the web page content, and essentially take control of a user's session within an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9v8p-m85m-f7mm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-9823

Advisory: Mautic vulnerable to reflected XSS in lead:addLeadTags - Quick Add
IDs: CVE-2025-9823, GHSA-9v8p-m85m-f7mm
Record: https://patchnext.com/advisories/cve-2025-9823 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mautic/core 6.0.5, 5.2.8, 4.4.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core: affected >= 4.4.0, < 4.4.17; >= 5.0.0-alpha, < 5.2.8; >= 6.0.0-alpha, < 6.0.5; fixed in 5.2.8, 4.4.17, 6.0.5

## Suggested inspection (read-only)
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9v8p-m85m-f7mm (GitHub-reviewed advisory GHSA-9v8p-m85m-f7mm lists affected ranges: Packagist mautic/core >=4.4.0 =5.0.0-alpha =6.0.0-alpha <6.0.5)

Commands are suggestions: review each one before running it.

Loading voting…