podman kube play symlink traversal vulnerability
CVE-2025-9566GHSA-wp3j-xq48-xpjw
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/containers/podman/v5
- Affected
- < 5.6.1
- Fixed in
- 5.6.1
Go github.com/containers/podman/v4
- Affected
- <= 4.9.5
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wp3j-xq48-xpjw lists affected ranges: Go github.com/containers/podman/v5 >=0 =0 <=4.9.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wp3j-xq48-xpjw lists affected ranges: Go github.com/containers/podman/v5 >=0 =0 <=4.9.5
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2025-9566: 1.16% estimated exploitation activity in the next 30 days; percentile 67.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The podman kube play command can overwrite host files when the kube file contains a ConfigMap or Secret volume mount and the volume already contains a symlink to a host file. This allows a malicious container to write to arbitrary files on the host BUT the attacker only controls the target path not the contents that will be written to the file. The contents are defined in the yaml file by the end user.
Requirements to exploit: podman kube play must be used with a ConfigMap or Secret volume mount AND must be run more than once on the same volume. All the attacker has to do is create the malicious symlink on the volume the first time it is started. After that all following starts would follow the symlink and write to the host location.
Patches Fixed in podman v5.6.1 https://github.com/containers/podman/commit/43fbde4e665fe6cee6921868f04b7ccd3de5ad89
Workarounds Don't use podman kube play with ConfigMap or Secret volume mounts.
PR with test for CI Adding on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-wp3j-xq48-xpjw
- Revision 2 · amended ·
Amended from ghsa record GHSA-wp3j-xq48-xpjw
- Revision 1 · created ·
Published from ghsa record GHSA-wp3j-xq48-xpjw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-9566 Advisory: podman kube play symlink traversal vulnerability IDs: CVE-2025-9566, GHSA-wp3j-xq48-xpjw Record: https://patchnext.com/advisories/cve-2025-9566 (revision 3, source checked 4 Nov 2026, 06:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/containers/podman/v5 5.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/containers/podman/v5: affected < 5.6.1; fixed in 5.6.1 - Go github.com/containers/podman/v4: affected <= 4.9.5 ## Suggested inspection (read-only) - Go github.com/containers/podman/v5: check the installed version with your package manager. - Go github.com/containers/podman/v4: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/containers/podman/v5, github.com/containers/podman/v4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wp3j-xq48-xpjw (GitHub-reviewed advisory GHSA-wp3j-xq48-xpjw lists affected ranges: Go github.com/containers/podman/v5 >=0 =0 <=4.9.5) - Verified: https://osv.dev/vulnerability/GHSA-wp3j-xq48-xpjw (OSV record GHSA-wp3j-xq48-xpjw lists affected ranges: Go github.com/containers/podman/v5 >=0 =0 <=4.9.5) Commands are suggestions: review each one before running it.
Loading voting…