Bouncy Castle for Java has Out-of-Bounds Write Vulnerability
CVE-2025-9340GHSA-g6rx-6wfx-gj74
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bouncycastle:bc-fips 2.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.bouncycastle:bc-fips
- Affected
- >= 2.1.0, <= 2.1.0
- Fixed in
- 2.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g6rx-6wfx-gj74 lists affected ranges: Maven org.bouncycastle:bc-fips >=2.1.0 <=2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 0.0 · CVSS:4.0/AV:P/AC:L/AT:P/PR:L/UI:A/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:N/AU:X/R:U/V:X/RE:M/U:Green · score source
- EPSS
- CVE-2025-9340: 0.18% estimated exploitation activity in the next 30 days; percentile 7.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Out-of-bounds Write vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java bc-fips on All (API modules). This vulnerability is associated with program files org/bouncycastle/jcajce/provider/BaseCipher. This issue affects Bouncy Castle for Java: from BC-FJA 2.1.0 through 2.1.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g6rx-6wfx-gj74
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-9340 Advisory: Bouncy Castle for Java has Out-of-Bounds Write Vulnerability IDs: CVE-2025-9340, GHSA-g6rx-6wfx-gj74 Record: https://patchnext.com/advisories/cve-2025-9340 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated (CVSS 0.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.bouncycastle:bc-fips 2.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.bouncycastle:bc-fips: affected >= 2.1.0, <= 2.1.0; fixed in 2.1.1 ## Suggested inspection (read-only) - Maven org.bouncycastle:bc-fips: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.bouncycastle:bc-fips. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g6rx-6wfx-gj74 (GitHub-reviewed advisory GHSA-g6rx-6wfx-gj74 lists affected ranges: Maven org.bouncycastle:bc-fips >=2.1.0 <=2.1.0) Commands are suggestions: review each one before running it.
Loading voting…