Skip to content

← Actionable
Critical, CVSS 9.1amended

cipher-base is missing type checks, leading to hash rewind and passing on crafted data

CVE-2025-9287GHSA-cpq7-6gpm-g9rc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cipher-base 1.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2025-9287: 0.55% estimated exploitation activity in the next 30 days; percentile 46.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary This affects e.g. create-hash (and crypto-browserify), so I'll describe the issue against that package Also affects create-hmac and other packages Node.js createHash works only on strings or instances of Buffer, TypedArray, or DataView. Missing input type checks (in npm create-hash polyfill of Node.js createHash) can allow types other than a well-formed Buffer or string, resulting in invalid values, hanging and rewinding the hash state (including turning a tagged hash into an untagged hash), or other generally undefined behaviour. Details See PoC PoC Output: This works with: But there are other types of input which lead to unchecked results Impact 1. Hash state rewind on {length: -x}. This is behind the PoC above, also this way an attacker can turn a tagged hash in cryptographic libraries into an untagged hash. 2. Value miscalculation, e.g. a collision is generated by { length: buf.length, ...buf, 0: buf[0] + 256 } This will result in the same hash as of buf, but can be…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cpq7-6gpm-g9rc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cpq7-6gpm-g9rc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-9287

Advisory: cipher-base is missing type checks, leading to hash rewind and passing on crafted data
IDs: CVE-2025-9287, GHSA-cpq7-6gpm-g9rc
Record: https://patchnext.com/advisories/cve-2025-9287 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cipher-base 1.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm cipher-base: affected <= 1.0.4; fixed in 1.0.5

## Suggested inspection (read-only)
- `npm ls cipher-base --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cipher-base.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cpq7-6gpm-g9rc (OSV record GHSA-cpq7-6gpm-g9rc lists affected ranges: npm cipher-base >=0 <1.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-cpq7-6gpm-g9rc (GitHub-reviewed advisory GHSA-cpq7-6gpm-g9rc lists affected ranges: npm cipher-base >=0 <=1.0.4)

Commands are suggestions: review each one before running it.

Loading voting…