Mattermost Open Redirect vulnerability
CVE-2025-9072GHSA-69j8-prx2-vx98
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 8.0.0-20250731063404-9eebaadf8f72; github.com/mattermost/mattermost-server 10.10.2, 10.9.5, 10.5.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- < 8.0.0-20250731063404-9eebaadf8f72
- Fixed in
- 8.0.0-20250731063404-9eebaadf8f72
Go github.com/mattermost/mattermost-server
- Affected
- >= 10.10.0, < 10.10.2>= 10.5.0, < 10.5.10>= 10.9.0, < 10.9.5
- Fixed in
- 10.10.2, 10.5.10, 10.9.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-69j8-prx2-vx98 lists affected ranges: Go github.com/mattermost/mattermost-server >=10.10.0 =10.5.0 =10.9.0 =0 <8.0.0-20250731063404-9eebaadf8f72
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
- EPSS
- CVE-2025-9072: 0.18% estimated exploitation activity in the next 30 days; percentile 7.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 10.10.x <= 10.10.1, 10.5.x <= 10.5.9, 10.9.x <= 10.9.4 fail to validate the redirectto parameter, allowing an attacker to craft a malicious link that, once a user authenticates with their SAML provider, could post the user’s cookies to an attacker-controlled URL.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-69j8-prx2-vx98
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-9072 Advisory: Mattermost Open Redirect vulnerability IDs: CVE-2025-9072, GHSA-69j8-prx2-vx98 Record: https://patchnext.com/advisories/cve-2025-9072 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20250731063404-9eebaadf8f72; github.com/mattermost/mattermost-server 10.10.2, 10.9.5, 10.5.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20250731063404-9eebaadf8f72; fixed in 8.0.0-20250731063404-9eebaadf8f72 - Go github.com/mattermost/mattermost-server: affected >= 10.10.0, < 10.10.2; >= 10.5.0, < 10.5.10; >= 10.9.0, < 10.9.5; fixed in 10.10.2, 10.5.10, 10.9.5 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-69j8-prx2-vx98 (GitHub-reviewed advisory GHSA-69j8-prx2-vx98 lists affected ranges: Go github.com/mattermost/mattermost-server >=10.10.0 =10.5.0 =10.9.0 =0 <8.0.0-20250731063404-9eebaadf8f72) Commands are suggestions: review each one before running it.
Loading voting…