Bouncy Castle for Java bcpkix, bcprov, bcpkix-fips on All (API modules) allows Excessive Allocation
CVE-2025-8916GHSA-4cx2-fc23-5wg6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bouncycastle:bcpkix-jdk18on 1.79; org.bouncycastle:bcpkix-jdk15on 1.79; org.bouncycastle:bcpkix-jdk15to18 1.79; org.bouncycastle:bcpkix-fips 2.0.8, 1.0.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.bouncycastle:bcpkix-jdk18on
- Affected
- >= 1.44, < 1.79
- Fixed in
- 1.79
Maven org.bouncycastle:bcpkix-jdk15on
- Affected
- >= 1.44, < 1.79
- Fixed in
- 1.79
Maven org.bouncycastle:bcpkix-jdk15to18
- Affected
- >= 1.44, < 1.79
- Fixed in
- 1.79
Maven org.bouncycastle:bcpkix-fips
- Affected
- >= 1.0.0, <= 1.0.7>= 2.0.0, <= 2.0.7
- Fixed in
- 1.0.8, 2.0.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4cx2-fc23-5wg6 lists affected ranges: Maven org.bouncycastle:bcpkix-fips >=1.0.0 =2.0.0 =1.44 =1.44 =1.44 <1.79
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/S:P/R:U/RE:M/U:Amber · score source
- EPSS
- CVE-2025-8916: 0.50% estimated exploitation activity in the next 30 days; percentile 42.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Allocation of Resources Without Limits or Throttling vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java bcpkix, bcprov, bcpkix-fips on All (API modules) allows Excessive Allocation. This vulnerability is associated with program files https://github.Com/bcgit/bc-java/blob/main/pkix/src/main/java/org/bouncycastle/pkix/jcajce/PKIXCertP... https://github.Com/bcgit/bc-java/blob/main/pkix/src/main/java/org/bouncycastle/pkix/jcajce/PKIXCertPathReviewer.java , https://github.Com/bcgit/bc-java/blob/main/prov/src/main/java/org/bouncycastle/x509/PKIXCertPathRevi... https://github.Com/bcgit/bc-java/blob/main/prov/src/main/java/org/bouncycastle/x509/PKIXCertPathReviewer.java . This issue affects Bouncy Castle for Java: from BC 1.44 through 1.78, from BCPKIX FIPS 1.0.0 through 1.0.7, from BCPKIX FIPS 2.0.0 through 2.0.7.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4cx2-fc23-5wg6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-8916 Advisory: Bouncy Castle for Java bcpkix, bcprov, bcpkix-fips on All (API modules) allows Excessive Allocation IDs: CVE-2025-8916, GHSA-4cx2-fc23-5wg6 Record: https://patchnext.com/advisories/cve-2025-8916 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.bouncycastle:bcpkix-jdk18on 1.79; org.bouncycastle:bcpkix-jdk15on 1.79; org.bouncycastle:bcpkix-jdk15to18 1.79; org.bouncycastle:bcpkix-fips 2.0.8, 1.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.bouncycastle:bcpkix-jdk18on: affected >= 1.44, < 1.79; fixed in 1.79 - Maven org.bouncycastle:bcpkix-jdk15on: affected >= 1.44, < 1.79; fixed in 1.79 - Maven org.bouncycastle:bcpkix-jdk15to18: affected >= 1.44, < 1.79; fixed in 1.79 - Maven org.bouncycastle:bcpkix-fips: affected >= 1.0.0, <= 1.0.7; >= 2.0.0, <= 2.0.7; fixed in 1.0.8, 2.0.8 ## Suggested inspection (read-only) - Maven org.bouncycastle:bcpkix-jdk18on: check the installed version with your package manager. - Maven org.bouncycastle:bcpkix-jdk15on: check the installed version with your package manager. - Maven org.bouncycastle:bcpkix-jdk15to18: check the installed version with your package manager. - Maven org.bouncycastle:bcpkix-fips: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.bouncycastle:bcpkix-jdk18on, org.bouncycastle:bcpkix-jdk15on, org.bouncycastle:bcpkix-jdk15to18, org.bouncycastle:bcpkix-fips. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4cx2-fc23-5wg6 (GitHub-reviewed advisory GHSA-4cx2-fc23-5wg6 lists affected ranges: Maven org.bouncycastle:bcpkix-fips >=1.0.0 =2.0.0 =1.44 =1.44 =1.44 <1.79) Commands are suggestions: review each one before running it.
Loading voting…