Bouncy Castle for Java on All (API modules) allows Excessive Allocation
CVE-2025-8885GHSA-67mf-3cr5-8w23
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bouncycastle:bc-fips 2.0.1, 1.0.2.6; org.bouncycastle:bcprov-jdk14 1.78; org.bouncycastle:bcprov-jdk15to18 1.78; org.bouncycastle:bctls-jdk15to18 1.78; org.bouncycastle:bctls-jdk14 1.78; 2 more packages under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.bouncycastle:bc-fips
- Affected
- >= 2.0.0, <= 2.0.0>= 1.0.0, < 1.0.2.6
- Fixed in
- 2.0.1, 1.0.2.6
Maven org.bouncycastle:bcprov-jdk14
- Affected
- >= 1.0, < 1.78
- Fixed in
- 1.78
Maven org.bouncycastle:bcprov-jdk15to18
- Affected
- >= 1.0, < 1.78
- Fixed in
- 1.78
Maven org.bouncycastle:bctls-jdk15to18
- Affected
- >= 1.0, < 1.78
- Fixed in
- 1.78
Maven org.bouncycastle:bctls-jdk14
- Affected
- >= 1.0, < 1.78
- Fixed in
- 1.78
Maven org.bouncycastle:bcprov-jdk18on
- Affected
- >= 1.0, < 1.78
- Fixed in
- 1.78
Maven org.bouncycastle:bctls-jdk18on
- Affected
- >= 1.0, < 1.78
- Fixed in
- 1.78
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-67mf-3cr5-8w23 lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=1.0 =1.0 =1.0 =1.0 =1.0 =1.0 =2.0.0 =1.0.0 <1.0.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/S:P/R:U/RE:M/U:Amber · score source
- EPSS
- CVE-2025-8885: 0.59% estimated exploitation activity in the next 30 days; percentile 48.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A resource allocation vulnerability exists in Bouncy Castle for Java (by Legion of the Bouncy Castle Inc.) that affects all API modules. The vulnerability allows attackers to cause excessive memory allocation through unbounded resource consumption, potentially leading to denial of service. The issue is located in the ASN1ObjectIdentifier.java file in the core module. This issue affects Bouncy Castle for Java: from BC 1.0 through 1.77, from BC-FJA 1.0.0 through 2.0.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-67mf-3cr5-8w23
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-8885 Advisory: Bouncy Castle for Java on All (API modules) allows Excessive Allocation IDs: CVE-2025-8885, GHSA-67mf-3cr5-8w23 Record: https://patchnext.com/advisories/cve-2025-8885 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.bouncycastle:bc-fips 2.0.1, 1.0.2.6; org.bouncycastle:bcprov-jdk14 1.78; org.bouncycastle:bcprov-jdk15to18 1.78; org.bouncycastle:bctls-jdk15to18 1.78; org.bouncycastle:bctls-jdk14 1.78; org.bouncycastle:bcprov-jdk18on 1.78; org.bouncycastle:bctls-jdk18on 1.78. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.bouncycastle:bc-fips: affected >= 2.0.0, <= 2.0.0; >= 1.0.0, < 1.0.2.6; fixed in 2.0.1, 1.0.2.6 - Maven org.bouncycastle:bcprov-jdk14: affected >= 1.0, < 1.78; fixed in 1.78 - Maven org.bouncycastle:bcprov-jdk15to18: affected >= 1.0, < 1.78; fixed in 1.78 - Maven org.bouncycastle:bctls-jdk15to18: affected >= 1.0, < 1.78; fixed in 1.78 - Maven org.bouncycastle:bctls-jdk14: affected >= 1.0, < 1.78; fixed in 1.78 - Maven org.bouncycastle:bcprov-jdk18on: affected >= 1.0, < 1.78; fixed in 1.78 - Maven org.bouncycastle:bctls-jdk18on: affected >= 1.0, < 1.78; fixed in 1.78 ## Suggested inspection (read-only) - Maven org.bouncycastle:bc-fips: check the installed version with your package manager. - Maven org.bouncycastle:bcprov-jdk14: check the installed version with your package manager. - Maven org.bouncycastle:bcprov-jdk15to18: check the installed version with your package manager. - Maven org.bouncycastle:bctls-jdk15to18: check the installed version with your package manager. - Maven org.bouncycastle:bctls-jdk14: check the installed version with your package manager. - Maven org.bouncycastle:bcprov-jdk18on: check the installed version with your package manager. - Maven org.bouncycastle:bctls-jdk18on: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.bouncycastle:bc-fips, org.bouncycastle:bcprov-jdk14, org.bouncycastle:bcprov-jdk15to18, org.bouncycastle:bctls-jdk15to18, org.bouncycastle:bctls-jdk14, org.bouncycastle:bcprov-jdk18on, org.bouncycastle:bctls-jdk18on. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-67mf-3cr5-8w23 (GitHub-reviewed advisory GHSA-67mf-3cr5-8w23 lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=1.0 =1.0 =1.0 =1.0 =1.0 =1.0 =2.0.0 =1.0.0 <1.0.2.6) Commands are suggestions: review each one before running it.
Loading voting…