pip's fallback tar extraction doesn't check symbolic links point to extraction directory
CVE-2025-8869GHSA-4xh5-x5gv-qwph
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pip 25.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pip
- Affected
- <= 25.2
- Fixed in
- 25.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4xh5-x5gv-qwph lists affected ranges: PyPI pip >=0 <25.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4xh5-x5gv-qwph lists affected ranges: PyPI pip >=0 <=25.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-8869: 0.49% estimated exploitation activity in the next 30 days; percentile 42.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When extracting a tar archive pip may not check symbolic links point into the extraction directory if the tarfile module doesn't implement PEP 706. Note that upgrading pip to a "fixed" version for this vulnerability doesn't fix all known vulnerabilities that are remediated by using a Python version that implements PEP 706. Note that this is a vulnerability in pip's fallback implementation of tar extraction for Python versions that don't implement PEP 706 and therefore are not secure to all vulnerabilities in the Python 'tarfile' module. If you're using a Python version that implements PEP 706 then pip doesn't use the "vulnerable" fallback code. Mitigations include upgrading to a version of pip that includes the fix, upgrading to a Python version that implements PEP 706 (Python =3.9.17, =3.10.12, =3.11.4, or =3.12), applying the linked patch, or inspecting source distributions (sdists) before installation as is already a best-practice.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4xh5-x5gv-qwph
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4xh5-x5gv-qwph
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-8869 Advisory: pip's fallback tar extraction doesn't check symbolic links point to extraction directory IDs: CVE-2025-8869, GHSA-4xh5-x5gv-qwph Record: https://patchnext.com/advisories/cve-2025-8869 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pip 25.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pip: affected <= 25.2; fixed in 25.3 ## Suggested inspection (read-only) - `python -m pip show pip`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pip. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4xh5-x5gv-qwph (OSV record GHSA-4xh5-x5gv-qwph lists affected ranges: PyPI pip >=0 <25.3 (fixed)) - Verified: https://github.com/advisories/GHSA-4xh5-x5gv-qwph (GitHub-reviewed advisory GHSA-4xh5-x5gv-qwph lists affected ranges: PyPI pip >=0 <=25.2) Commands are suggestions: review each one before running it.
Loading voting…