LangGraph's SQLite store implementation has a SQL Injection Vulnerability
CVE-2025-8709GHSA-4h97-wpxp-3757
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph-checkpoint-sqlite 2.0.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langgraph-checkpoint-sqlite
- Affected
- <= 2.0.10
- Fixed in
- 2.0.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4h97-wpxp-3757 lists affected ranges: PyPI langgraph-checkpoint-sqlite >=0 <2.0.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4h97-wpxp-3757 lists affected ranges: PyPI langgraph-checkpoint-sqlite >=0 <=2.0.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2025-8709: 0.22% estimated exploitation activity in the next 30 days; percentile 12.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A SQL injection vulnerability exists in the langchain-ai/langgraph repository, specifically in the LangGraph's SQLite store implementation. The affected version is langgraph-checkpoint-sqlite 2.0.10. The vulnerability arises from improper handling of filter operators ($eq, $ne, $gt, $lt, $gte, $lte) where direct string concatenation is used without proper parameterization. This allows attackers to inject arbitrary SQL, leading to unauthorized access to all documents, data exfiltration of sensitive fields such as passwords and API keys, and a complete bypass of application-level security filters.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4h97-wpxp-3757
- Revision 1 · created ·
Published from osv record GHSA-4h97-wpxp-3757
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-8709 Advisory: LangGraph's SQLite store implementation has a SQL Injection Vulnerability IDs: CVE-2025-8709, GHSA-4h97-wpxp-3757 Record: https://patchnext.com/advisories/cve-2025-8709 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langgraph-checkpoint-sqlite 2.0.11. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langgraph-checkpoint-sqlite: affected <= 2.0.10; fixed in 2.0.11 ## Suggested inspection (read-only) - `python -m pip show langgraph-checkpoint-sqlite`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langgraph-checkpoint-sqlite. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4h97-wpxp-3757 (OSV record GHSA-4h97-wpxp-3757 lists affected ranges: PyPI langgraph-checkpoint-sqlite >=0 <2.0.11 (fixed)) - Verified: https://github.com/advisories/GHSA-4h97-wpxp-3757 (GitHub-reviewed advisory GHSA-4h97-wpxp-3757 lists affected ranges: PyPI langgraph-checkpoint-sqlite >=0 <=2.0.10) Commands are suggestions: review each one before running it.
Loading voting…