Concrete CMS is vulnerable to Stored XSS from Home Folder on Members Dashboard page
CVE-2025-8573GHSA-c5xf-rmv4-j85h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (concrete5/concrete5 9.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist concrete5/concrete5
- Affected
- >= 9.0.0RC1, < 9.4.3
- Fixed in
- 9.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c5xf-rmv4-j85h lists affected ranges: Packagist concrete5/concrete5 >=9.0.0RC1 <9.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.0 · CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-8573: 0.47% estimated exploitation activity in the next 30 days; percentile 41.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Concrete CMS versions 9 through 9.4.2 are vulnerable to Stored XSS from Home Folder on Members Dashboard page. Version 8 was not affected. A rogue admin could set up a malicious folder containing XSS to which users could be directed upon login.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c5xf-rmv4-j85h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-8573 Advisory: Concrete CMS is vulnerable to Stored XSS from Home Folder on Members Dashboard page IDs: CVE-2025-8573, GHSA-c5xf-rmv4-j85h Record: https://patchnext.com/advisories/cve-2025-8573 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: concrete5/concrete5 9.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist concrete5/concrete5: affected >= 9.0.0RC1, < 9.4.3; fixed in 9.4.3 ## Suggested inspection (read-only) - Packagist concrete5/concrete5: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on concrete5/concrete5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c5xf-rmv4-j85h (GitHub-reviewed advisory GHSA-c5xf-rmv4-j85h lists affected ranges: Packagist concrete5/concrete5 >=9.0.0RC1 <9.4.3) Commands are suggestions: review each one before running it.
Loading voting…