Skip to content

← Actionable
Medium, CVSS 4.9

Mattermost has Potential Server Crash due to Unvalidated Import Data

CVE-2025-8402GHSA-h469-4fcf-p23h

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/mattermost/mattermost/server/v8

    Affected
    < 8.0.0-20250708173752-d6b35c41f0ae5
    Fixed in
    8.0.0-20250708173752-d6b35c41f0ae5
  • Go github.com/mattermost/mattermost-server/v6

    Affected
    <= 6.7.2
    Fixed in
    no fixed version recorded
  • Go github.com/mattermost/mattermost-server

    Affected
    >= 10.8.0, <= 10.8.3>= 10.5.0, <= 10.5.8>= 10.9.0, <= 10.9.3>= 10.10.0, <= 10.10.0>= 9.11.0, <= 9.11.17
    Fixed in
    10.9.4, 10.5.9, 10.10.1, 9.11.18, 10.8.4
  • Go github.com/mattermost/mattermost-server/v5

    Affected
    <= 5.39.3
    Fixed in
    no fixed version recorded

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-h469-4fcf-p23h lists affected ranges: Go github.com/mattermost/mattermost-server >=10.8.0 =10.5.0 =10.9.0 =10.10.0 =9.11.0 =0 =0 =0 <=6.7.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-8402: 0.32% estimated exploitation activity in the next 30 days; percentile 25.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.0, 10.9.x <= 10.9.3 fail to validate import data which allows a system admin to crash the server via the bulk import feature.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h469-4fcf-p23h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-8402

Advisory: Mattermost has Potential Server Crash due to Unvalidated Import Data
IDs: CVE-2025-8402, GHSA-h469-4fcf-p23h
Record: https://patchnext.com/advisories/cve-2025-8402 (revision 1, source checked 26 Oct 2026, 15:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20250708173752-d6b35c41f0ae5; github.com/mattermost/mattermost-server 10.10.1, 10.9.4, 10.8.4, 10.5.9, 9.11.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20250708173752-d6b35c41f0ae5; fixed in 8.0.0-20250708173752-d6b35c41f0ae5
- Go github.com/mattermost/mattermost-server/v6: affected <= 6.7.2
- Go github.com/mattermost/mattermost-server: affected >= 10.8.0, <= 10.8.3; >= 10.5.0, <= 10.5.8; >= 10.9.0, <= 10.9.3; >= 10.10.0, <= 10.10.0; >= 9.11.0, <= 9.11.17; fixed in 10.9.4, 10.5.9, 10.10.1, 9.11.18, 10.8.4
- Go github.com/mattermost/mattermost-server/v5: affected <= 5.39.3

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server/v6: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server/v5: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v6, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h469-4fcf-p23h (GitHub-reviewed advisory GHSA-h469-4fcf-p23h lists affected ranges: Go github.com/mattermost/mattermost-server >=10.8.0 =10.5.0 =10.9.0 =10.10.0 =9.11.0 =0 =0 =0 <=6.7.2)

Commands are suggestions: review each one before running it.

Loading voting…