Skip to content

← Actionable
High, CVSS 7.8amended

ssrfcheck: SSRF Bypass Caused by Failure to Classify Reserved IP Address Space as Invalid

CVE-2025-8267GHSA-p4hc-9pjh-55c8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ssrfcheck 1.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-8267: 0.53% estimated exploitation activity in the next 30 days; percentile 45.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SSRF Bypass in ssrfcheck - fails to classify reserved IP address space as invalid ssrfcheck is an npm package that serves to provide protection from SSRF by validating URLs or hostname inputs. Resources: Project's GitHub code repository: https://github.com/felippe-regazio/ssrfcheck Project's npm package: https://www.npmjs.com/package/ssrfcheck Vulnerability The ssrfcheck package maintains a denylist of IP addresses and ranges to check against when validating if an IP address is to be considered as safe or not. However, the IP address list used for the denylist is incomplete and misses a reserved IP address space as defined by the IANA (Internet Assigned Numbers Authority): - 224.0.0.0/4 - Multicast Practically, this reserved IP address space is used for multicast traffic and would most commonly be used for reserved local communication over network protocols such as UDP, which would make it less likely to be used in a typical SSRF attack in practice. However, such reserved IP address…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p4hc-9pjh-55c8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-p4hc-9pjh-55c8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-8267

Advisory: ssrfcheck: SSRF Bypass Caused by Failure to Classify Reserved IP Address Space as Invalid
IDs: CVE-2025-8267, GHSA-p4hc-9pjh-55c8
Record: https://patchnext.com/advisories/cve-2025-8267 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ssrfcheck 1.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ssrfcheck: affected < 1.2.0; fixed in 1.2.0

## Suggested inspection (read-only)
- `npm ls ssrfcheck --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ssrfcheck.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p4hc-9pjh-55c8 (OSV record GHSA-p4hc-9pjh-55c8 lists affected ranges: npm ssrfcheck >=0 <1.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-p4hc-9pjh-55c8 (GitHub-reviewed advisory GHSA-p4hc-9pjh-55c8 lists affected ranges: npm ssrfcheck >=0 <1.2.0)

Commands are suggestions: review each one before running it.

Loading voting…