z-push/z-push-dev SQL Injection Vulnerability
CVE-2025-8264GHSA-w832-w3p8-cw29
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (z-push/z-push-dev 2.7.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist z-push/z-push-dev
- Affected
- < 2.7.6
- Fixed in
- 2.7.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w832-w3p8-cw29 lists affected ranges: Packagist z-push/z-push-dev >=0 <2.7.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2025-8264: 0.45% estimated exploitation activity in the next 30 days; percentile 38.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package z-push/z-push-dev before 2.7.6 are vulnerable to SQL Injection due to unparameterized queries in the IMAP backend. An attacker can inject malicious commands by manipulating the username field in basic authentication. This allows the attacker to access and potentially modify or delete sensitive data from a linked third-party database. Note: This vulnerability affects Z-Push installations that utilize the IMAP backend and have the IMAPFROMSQLQUERY option configured. Mitigation Change configuration to use the default or LDAP in backend/imap/config.php php define('IMAPDEFAULTFROM', ''); or php define('IMAPDEFAULTFROM', 'ldap');
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w832-w3p8-cw29
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-8264 Advisory: z-push/z-push-dev SQL Injection Vulnerability IDs: CVE-2025-8264, GHSA-w832-w3p8-cw29 Record: https://patchnext.com/advisories/cve-2025-8264 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: z-push/z-push-dev 2.7.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist z-push/z-push-dev: affected < 2.7.6; fixed in 2.7.6 ## Suggested inspection (read-only) - Packagist z-push/z-push-dev: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on z-push/z-push-dev. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w832-w3p8-cw29 (GitHub-reviewed advisory GHSA-w832-w3p8-cw29 lists affected ranges: Packagist z-push/z-push-dev >=0 <2.7.6) Commands are suggestions: review each one before running it.
Loading voting…