Skip to content

← Actionable
Critical, CVSS 9.4amended

form-data uses unsafe random function in form-data for choosing boundary

CVE-2025-7783GHSA-fjxv-7rqg-78g4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (form-data 4.0.4, 3.0.4, 2.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm form-data

    Affected
    < 2.5.4>= 3.0.0, < 3.0.4>= 4.0.0, < 4.0.4
    Fixed in
    3.0.4, 2.5.4, 4.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2025-7783: 1.81% estimated exploitation activity in the next 30 days; percentile 78.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary form-data uses Math.random() to select a boundary value for multipart form-encoded data. This can lead to a security issue if an attacker: 1. can observe other values produced by Math.random in the target application, and 2. can control one field of a request made using form-data Because the values of Math.random() are pseudo-random and predictable (see: https://blog.securityevaluators.com/hacking-the-javascript-lottery-80cc437e3b7f), an attacker who can observe a few sequential values can determine the state of the PRNG and predict future values, includes those used to generate form-data's boundary value. The allows the attacker to craft a value that contains a boundary value, allowing them to inject additional parameters into the request. This is largely the same vulnerability as was recently found in undici by parrot409 -- I'm not affiliated with that researcher but want to give credit where credit is due! My PoC is largely based on their work. Details The culprit is this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fjxv-7rqg-78g4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-fjxv-7rqg-78g4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-7783

Advisory: form-data uses unsafe random function in form-data for choosing boundary
IDs: CVE-2025-7783, GHSA-fjxv-7rqg-78g4
Record: https://patchnext.com/advisories/cve-2025-7783 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: form-data 4.0.4, 3.0.4, 2.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm form-data: affected < 2.5.4; >= 3.0.0, < 3.0.4; >= 4.0.0, < 4.0.4; fixed in 3.0.4, 2.5.4, 4.0.4

## Suggested inspection (read-only)
- `npm ls form-data --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on form-data.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fjxv-7rqg-78g4 (OSV record GHSA-fjxv-7rqg-78g4 lists affected ranges: npm form-data >=0 =3.0.0 =4.0.0 <4.0.4 (fixed))
- Verified: https://github.com/advisories/GHSA-fjxv-7rqg-78g4 (GitHub-reviewed advisory GHSA-fjxv-7rqg-78g4 lists affected ranges: npm form-data >=0 =3.0.0 =4.0.0 <4.0.4)

Commands are suggestions: review each one before running it.

Loading voting…