llama-index has Insecure Temporary File
CVE-2025-7707GHSA-rg9h-vx28-xxp5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index 0.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI llama-index
- Affected
- < 0.13.0
- Fixed in
- 0.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rg9h-vx28-xxp5 lists affected ranges: PyPI llama-index >=0 <0.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rg9h-vx28-xxp5 lists affected ranges: PyPI llama-index >=0 <0.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2025-7707: 0.19% estimated exploitation activity in the next 30 days; percentile 8.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The llamaindex library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rg9h-vx28-xxp5
- Revision 1 · created ·
Published from osv record GHSA-rg9h-vx28-xxp5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-7707 Advisory: llama-index has Insecure Temporary File IDs: CVE-2025-7707, GHSA-rg9h-vx28-xxp5 Record: https://patchnext.com/advisories/cve-2025-7707 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: llama-index 0.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI llama-index: affected < 0.13.0; fixed in 0.13.0 ## Suggested inspection (read-only) - `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on llama-index. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rg9h-vx28-xxp5 (OSV record GHSA-rg9h-vx28-xxp5 lists affected ranges: PyPI llama-index >=0 <0.13.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rg9h-vx28-xxp5 (GitHub-reviewed advisory GHSA-rg9h-vx28-xxp5 lists affected ranges: PyPI llama-index >=0 <0.13.0) Commands are suggestions: review each one before running it.
Loading voting…