Skip to content

← Actionable
Medium, CVSS 5.2

operator-sdk: privilege escalation due to incorrect permissions of /etc/passwd

CVE-2025-7195GHSA-856v-8qm2-9wjv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/operator-framework/operator-sdk 0.15.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.2 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:L/I:H/A:L
EPSS
  • CVE-2025-7195: 0.24% estimated exploitation activity in the next 30 days; percentile 15.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Early versions of Operator-SDK provided an insecure method to allow operator containers to run in environments that used a random UID. Operator-SDK before 0.15.2 provided a script, usersetup, which modifies the permissions of the /etc/passwd file to 664 during build time. Developers who used Operator-SDK before 0.15.2 to scaffold their operator may still be impacted by this if the insecure usersetup script is still being used to build new container images. In affected images, the /etc/passwd file was created during build time with group-writable permissions and a group ownership of root (gid=0). An attacker who can execute commands within an affected container, even as a non-root user, may be able to leverage their membership in the root group to modify the /etc/passwd file. This could allow the attacker to add a new user with any arbitrary UID, including UID 0, leading to full root privileges within the container.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-856v-8qm2-9wjv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-7195

Advisory: operator-sdk: privilege escalation due to incorrect permissions of /etc/passwd
IDs: CVE-2025-7195, GHSA-856v-8qm2-9wjv
Record: https://patchnext.com/advisories/cve-2025-7195 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/operator-framework/operator-sdk 0.15.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/operator-framework/operator-sdk: affected < 0.15.2; fixed in 0.15.2

## Suggested inspection (read-only)
- Go github.com/operator-framework/operator-sdk: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/operator-framework/operator-sdk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-856v-8qm2-9wjv (GitHub-reviewed advisory GHSA-856v-8qm2-9wjv lists affected ranges: Go github.com/operator-framework/operator-sdk >=0 <0.15.2)

Commands are suggestions: review each one before running it.

Loading voting…