Better Auth URL parameter HTML Injection (Reflected Cross-Site scripting)
CVE-2025-71404GHSA-9x4v-xfq5-m8x5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.1.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm better-auth
- Affected
- >= 0.0.2, < 1.1.16
- Fixed in
- 1.1.16
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9x4v-xfq5-m8x5 lists affected ranges: npm better-auth >=0.0.2 <1.1.16 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9x4v-xfq5-m8x5 lists affected ranges: npm better-auth >=0.0.2 <1.1.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-71404: 0.72% estimated exploitation activity in the next 30 days; percentile 53.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The better-auth /api/auth/error page was vulnerable to HTML injection, resulting in a reflected cross-site scripting (XSS) vulnerability. Details The value of error URL parameter was reflected as HTML on the error page: https://github.com/better-auth/better-auth/blob/05ada0b79dbcac93cc04ceb79b23ca598d07830c/packages/better-auth/src/api/routes/error.ts#L81 Impact An attacker who exploited this vulnerability by coercing a user to visit a specially-crafted URL could execute arbitrary JavaScript in the context of the user's browser.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9x4v-xfq5-m8x5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9x4v-xfq5-m8x5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-71404 Advisory: Better Auth URL parameter HTML Injection (Reflected Cross-Site scripting) IDs: CVE-2025-71404, GHSA-9x4v-xfq5-m8x5 Record: https://patchnext.com/advisories/cve-2025-71404 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: better-auth 1.1.16. A vendor fix does not mean a deployment is fixed. ## Affected components - npm better-auth: affected >= 0.0.2, < 1.1.16; fixed in 1.1.16 ## Suggested inspection (read-only) - `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on better-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9x4v-xfq5-m8x5 (OSV record GHSA-9x4v-xfq5-m8x5 lists affected ranges: npm better-auth >=0.0.2 <1.1.16 (fixed)) - Verified: https://github.com/advisories/GHSA-9x4v-xfq5-m8x5 (GitHub-reviewed advisory GHSA-9x4v-xfq5-m8x5 lists affected ranges: npm better-auth >=0.0.2 <1.1.16) Commands are suggestions: review each one before running it.
Loading voting…