Better Auth's multi-session sign-out hook allows forged cookies to revoke arbitrary sessions
CVE-2025-71402GHSA-wmjr-v86c-m9jj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm better-auth
- Affected
- >= 1.3.34, < 1.4.0
- Fixed in
- 1.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wmjr-v86c-m9jj lists affected ranges: npm better-auth >=1.3.34 <1.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wmjr-v86c-m9jj lists affected ranges: npm better-auth >=1.3.34 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2025-71402: 0.27% estimated exploitation activity in the next 30 days; percentile 18.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A vulnerability was identified in the multi-session plugin for Better Auth, specifically in the /sign-out after-hook. The hook trusts raw multi-session cookies and forwards the extracted values directly to internalAdapter.deleteSessions without verifying the cookie signature. Because cookie values are not validated with getSignedCookie (or any equivalent check), an attacker can supply a forged multi- cookie to trigger deletion of arbitrary session tokens.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wmjr-v86c-m9jj
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wmjr-v86c-m9jj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-71402 Advisory: Better Auth's multi-session sign-out hook allows forged cookies to revoke arbitrary sessions IDs: CVE-2025-71402, GHSA-wmjr-v86c-m9jj Record: https://patchnext.com/advisories/cve-2025-71402 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: better-auth 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm better-auth: affected >= 1.3.34, < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on better-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wmjr-v86c-m9jj (OSV record GHSA-wmjr-v86c-m9jj lists affected ranges: npm better-auth >=1.3.34 <1.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wmjr-v86c-m9jj (GitHub-reviewed advisory GHSA-wmjr-v86c-m9jj lists affected ranges: npm better-auth >=1.3.34 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…