Better Auth affected by external request basePath modification DoS
CVE-2025-71401GHSA-569q-mpph-wgww
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm better-auth
- Affected
- < 1.4.2
- Fixed in
- 1.4.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-569q-mpph-wgww lists affected ranges: npm better-auth >=0 <1.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-569q-mpph-wgww lists affected ranges: npm better-auth >=0 <1.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-71401: 0.46% estimated exploitation activity in the next 30 days; percentile 39.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Affected versions of Better Auth allow an external request to configure baseURL when it isn’t defined through any other means. This can be abused to poison the router’s base path, causing all routes to return 404 for all users. This issue is only exploitable when baseURL is not explicitly configured (e.g., BETTERAUTHURL is missing) and the attacker is able to make the very first request to the server after startup. In properly configured environments or typical managed hosting platforms, this fallback behavior cannot be reached. Details A combination of X-Forwarded-Host and X-Forwarded-Proto is implicitly trusted. This allows the first request to configure baseURL whenever it is not explicitly configured. Here's the code that reads the headers: <img width="631" height="219" alt="headers" src="https://github.com/user-attachments/assets/b3fb0078-a62f-4058-9d0b-4afbd30c4953" / Here's the call to getBaseURL(), the result is assigned to ctx.baseURL. <img width="838" height="414"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-569q-mpph-wgww
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-569q-mpph-wgww
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-71401 Advisory: Better Auth affected by external request basePath modification DoS IDs: CVE-2025-71401, GHSA-569q-mpph-wgww Record: https://patchnext.com/advisories/cve-2025-71401 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: better-auth 1.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm better-auth: affected < 1.4.2; fixed in 1.4.2 ## Suggested inspection (read-only) - `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on better-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-569q-mpph-wgww (OSV record GHSA-569q-mpph-wgww lists affected ranges: npm better-auth >=0 <1.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-569q-mpph-wgww (GitHub-reviewed advisory GHSA-569q-mpph-wgww lists affected ranges: npm better-auth >=0 <1.4.2) Commands are suggestions: review each one before running it.
Loading voting…