Skip to content

← Actionable
High, CVSS 8.6amended

Better Auth's rou3 Dependency has Double-Slash Path Normalization which can Bypass disabledPaths Config and Rate Limits

CVE-2025-71399GHSA-x732-6j76-qmhm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
EPSS
  • CVE-2025-71399: 0.52% estimated exploitation activity in the next 30 days; percentile 44.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An issue in the underlying router library rou3 can cause /path and //path to be treated as identical routes. If your environment does not normalize incoming URLs (e.g., by collapsing multiple slashes), this can allow bypasses of disabledPaths and path-based rate limits. Details Better Auth uses better-call, which internally relies on rou3 for routing. Affected versions of rou3 normalize paths by removing empty segments. As a result: /sign-in/email //sign-in/email ///sign-in/email …all resolve to the same route. Some production setups automatically collapse multiple slashes. This includes: Vercel with Nextjs (default) Cloudflare - when normalize to urls origin is enabled (https://developers.cloudflare.com/rules/normalization/settings/#normalize-urls-to-origin) In these environments and other configurations where //path reach Better Auth as /path, the issue does not apply. Fix Updating rou3 to the latest version resolves the issue: better-call previously depended on "rou3":…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x732-6j76-qmhm

  2. Revision 1 · created ·

    Published from osv record GHSA-x732-6j76-qmhm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-71399

Advisory: Better Auth's rou3 Dependency has Double-Slash Path Normalization which can Bypass disabledPaths Config and Rate Limits
IDs: CVE-2025-71399, GHSA-x732-6j76-qmhm
Record: https://patchnext.com/advisories/cve-2025-71399 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: better-auth 1.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm better-auth: affected < 1.4.5; fixed in 1.4.5

## Suggested inspection (read-only)
- `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on better-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x732-6j76-qmhm (OSV record GHSA-x732-6j76-qmhm lists affected ranges: npm better-auth >=0 <1.4.5 (fixed))
- Verified: https://github.com/advisories/GHSA-x732-6j76-qmhm (GitHub-reviewed advisory GHSA-x732-6j76-qmhm lists affected ranges: npm better-auth >=0 <1.4.5)

Commands are suggestions: review each one before running it.

Loading voting…