Skip to content

← Actionable
Medium, CVSS 5.8

SurrealDB bypass of deny-net flags via redirect results in server-side request forgery (SSRF)

CVE-2025-71398GHSA-5q9x-554g-9jgg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 2.2.2, 2.1.5, 2.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io surrealdb

    Affected
    >= 2.2.0, < 2.2.2>= 2.1.0, < 2.1.5< 2.0.5
    Fixed in
    2.1.5, 2.2.2, 2.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:L/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-71398: 0.33% estimated exploitation activity in the next 30 days; percentile 26.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SurrealDB offers http functions that can access external network endpoints. A typical, albeit not recommended configuration would be to start SurrealDB with all network connections allowed with the exception of a deny list. For example, surreal start --allow-net --deny-net 10.0.0.0/8 will allow all network connections except to the 10.0.0.0/8 block. An authenticated user of SurrealDB can use redirects to bypass this restriction. For example by hosting a server on the public internet which redirects to the IP addresses blocked by the administrator of the SurrealDB server via HTTP 301 or 307 response codes. When sending SurrealDB statements containing the http:: functions to the attacker controlled host, the SurrealDB server will follow the redirects to the blocked IP address. Because the statements also return the responses to the attacker, this issue constitutes a full SSRF vulnerability. This issue was discovered and patched during an code audit and penetration test of SurrealDB by…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5q9x-554g-9jgg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-71398

Advisory: SurrealDB bypass of deny-net flags via redirect results in server-side request forgery (SSRF)
IDs: CVE-2025-71398, GHSA-5q9x-554g-9jgg
Record: https://patchnext.com/advisories/cve-2025-71398 (revision 1, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: surrealdb 2.2.2, 2.1.5, 2.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io surrealdb: affected >= 2.2.0, < 2.2.2; >= 2.1.0, < 2.1.5; < 2.0.5; fixed in 2.1.5, 2.2.2, 2.0.5

## Suggested inspection (read-only)
- crates.io surrealdb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on surrealdb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5q9x-554g-9jgg (GitHub-reviewed advisory GHSA-5q9x-554g-9jgg lists affected ranges: crates.io surrealdb >=2.2.0 =2.1.0 =0 <2.0.5)

Commands are suggestions: review each one before running it.

Loading voting…