Skip to content

← Actionable
Medium, CVSS 5.8amended

SurrealDB allows bypass of deny-net flags via DNS resolution

CVE-2025-71390GHSA-m3c3-78fh-w3w7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (SurrealDB 3.0.0-alpha.7, 2.3.6, 2.2.6, 2.1.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io SurrealDB

    Affected
    >= 2.1.0, < 2.1.8>= 2.2.0, < 2.2.6>= 3.0.0-alpha.1, < 3.0.0-alpha.7>= 2.3.0, < 2.3.6
    Fixed in
    2.1.8, 2.2.6, 3.0.0-alpha.7, 2.3.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:L/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-71390: 0.45% estimated exploitation activity in the next 30 days; percentile 39.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SurrealDB offers http functions that can access external network endpoints. A typical, albeit not recommended configuration would be to start SurrealDB with all network connections allowed with the exception of a deny list. For example, `surreal start --allow-net --deny-net 10.0.0.0/8` will allow all network connections except to the 10.0.0.0/8 block. An authenticated user of SurrealDB can use bypass this restriction, using `http:: ( )` functions where the hostname resolves to an IP within the `--deny-net` block. For example if a SurrealDB administrator wanted to restrict access to other services within a private network and thus set the `--deny-net` to a network IP range, this could be circumvented by an attacker leveraging DNS records and hostname resolution. When sending SurrealDB statements containing the `http::*` functions, if the hostname resolves…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 1 · created ·

    Published from osv record GHSA-m3c3-78fh-w3w7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-71390

Advisory: SurrealDB allows bypass of deny-net flags via DNS resolution
IDs: CVE-2025-71390, GHSA-m3c3-78fh-w3w7
Record: https://patchnext.com/advisories/cve-2025-71390 (revision 2, source checked 25 Oct 2026, 04:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: SurrealDB 3.0.0-alpha.7, 2.3.6, 2.2.6, 2.1.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io SurrealDB: affected >= 2.1.0, < 2.1.8; >= 2.2.0, < 2.2.6; >= 3.0.0-alpha.1, < 3.0.0-alpha.7; >= 2.3.0, < 2.3.6; fixed in 2.1.8, 2.2.6, 3.0.0-alpha.7, 2.3.6

## Suggested inspection (read-only)
- crates.io SurrealDB: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on SurrealDB.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m3c3-78fh-w3w7 (OSV record GHSA-m3c3-78fh-w3w7 lists affected ranges: crates.io SurrealDB >=2.1.0 =2.2.0 =3.0.0-alpha.1 =2.3.0 <2.3.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…