Skip to content

← Actionable
Medium, CVSS 4.3amended

vLLM vulnerable to Regular Expression Denial of Service

CVE-2025-71379GHSA-j828-28rj-hfhp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.6.3, < 0.9.0
    Fixed in
    0.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2025-71379: 0.48% estimated exploitation activity in the next 30 days; percentile 41.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A recent review identified several regular expressions in the vllm codebase that are susceptible to Regular Expression Denial of Service (ReDoS) attacks. These patterns, if fed with crafted or malicious input, may cause severe performance degradation due to catastrophic backtracking. 1. vllm/lora/utils.py Line 173 https://github.com/vllm-project/vllm/blob/2858830c39da0ae153bc1328dbba7680f5fbebe1/vllm/lora/utils.py#L173 Risk Description: - The regex r"\((.?)\)\$?$" matches content inside parentheses. If input such as ((((a|)+)+)+) is passed in, it can cause catastrophic backtracking, leading to a ReDoS vulnerability. - Using .? (non-greedy match) inside group parentheses can be highly sensitive to input length and nesting complexity. Remediation Suggestions: - Limit the input string length. - Use a non-recursive matching approach, or write a regex with stricter content constraints. - Consider using possessive quantifiers or atomic groups (not supported in Python yet), or split…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j828-28rj-hfhp

  2. Revision 1 · created ·

    Published from osv record GHSA-j828-28rj-hfhp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-71379

Advisory: vLLM vulnerable to Regular Expression Denial of Service
IDs: CVE-2025-71379, GHSA-j828-28rj-hfhp
Record: https://patchnext.com/advisories/cve-2025-71379 (revision 2, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.6.3, < 0.9.0; fixed in 0.9.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j828-28rj-hfhp (OSV record GHSA-j828-28rj-hfhp lists affected ranges: PyPI vllm >=0.6.3 <0.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-j828-28rj-hfhp (GitHub-reviewed advisory GHSA-j828-28rj-hfhp lists affected ranges: PyPI vllm >=0.6.3 <0.9.0)

Commands are suggestions: review each one before running it.

Loading voting…