Picklescan failed to detect to some unsafe global function in Numpy library
CVE-2025-71355GHSA-fj43-3qmq-673f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (picklescan 0.0.25), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI picklescan
- Affected
- < 0.0.25
- Fixed in
- 0.0.25
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fj43-3qmq-673f lists affected ranges: PyPI picklescan >=0 <0.0.25 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fj43-3qmq-673f lists affected ranges: PyPI picklescan >=0 <0.0.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-71355: 0.63% estimated exploitation activity in the next 30 days; percentile 50.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An unsafe deserialization vulnerability in Python’s pickle module allows an attacker to bypass static analysis tools like Picklescan and execute arbitrary code during deserialization. This can be exploited by import some built-in function in Numpy library that indrectly call some dangerous function like exec() to execute some python code as a parameter, which the attacker can import dangerous library inside like os library and execute arbitrary OS commands. Details Pickle’s deserialization process is known to allow execution of function via reduce method. While Picklescan is meant to detect such exploits, this attack evades detection by calling function in Numpy library that call dangerous function like exec(). And since Numpy library wasn't inside unsafe globals blacklist, it may not raise red flag in the security scan. The attack payload executes in the following steps: - First, the attacker craft the payload by import runstring function in numpy.testing.private.utils -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fj43-3qmq-673f
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-fj43-3qmq-673f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-71355 Advisory: Picklescan failed to detect to some unsafe global function in Numpy library IDs: CVE-2025-71355, GHSA-fj43-3qmq-673f Record: https://patchnext.com/advisories/cve-2025-71355 (revision 3, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: picklescan 0.0.25. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI picklescan: affected < 0.0.25; fixed in 0.0.25 ## Suggested inspection (read-only) - `python -m pip show picklescan`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on picklescan. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fj43-3qmq-673f (OSV record GHSA-fj43-3qmq-673f lists affected ranges: PyPI picklescan >=0 <0.0.25 (fixed)) - Verified: https://github.com/advisories/GHSA-fj43-3qmq-673f (GitHub-reviewed advisory GHSA-fj43-3qmq-673f lists affected ranges: PyPI picklescan >=0 <0.0.25) Commands are suggestions: review each one before running it.
Loading voting…