Flowise doesn't Prevent Bypass of Password Confirmation through Unverified Email Change (credentials)
CVE-2025-71337GHSA-x39m-3393-3qp4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-ui 3.0.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm flowise-ui
- Affected
- < 3.0.10
- Fixed in
- 3.0.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x39m-3393-3qp4 lists affected ranges: npm flowise-ui >=0 <3.0.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x39m-3393-3qp4 lists affected ranges: npm flowise-ui >=0 <3.0.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- EPSS
- CVE-2025-71337: 0.42% estimated exploitation activity in the next 30 days; percentile 36.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Unverified Email Change - Email as part of Credential / Unverified Account Recovery Channel Change The application allows changing the account email address (used as a login identifier and/or password recovery address) without verifying the requester’s authority to make that change (no confirmation to the old email, no authentication step). Because email often functions as a credential or recovery channel, unverified email changes enable attackers to take over accounts by switching the account’s recovery/login address. Details Occurence - code: https://github.com/FlowiseAI/Flowise/blob/main/packages/ui/src/views/account/index.jsx#L211 Remote and physical scenarios can be considered. PoC Repro steps: 1. As logged in user https://cloud.flowiseai.com/account scroll down to 'Profile' section 2. Change email to the new email 3. Notice Unverified Password Change (authenticated change without current password) Later this email is needed as credentials to log in or reset password…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x39m-3393-3qp4
- Revision 1 · created ·
Published from osv record GHSA-x39m-3393-3qp4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-71337 Advisory: Flowise doesn't Prevent Bypass of Password Confirmation through Unverified Email Change (credentials) IDs: CVE-2025-71337, GHSA-x39m-3393-3qp4 Record: https://patchnext.com/advisories/cve-2025-71337 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise-ui 3.0.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise-ui: affected < 3.0.10; fixed in 3.0.10 ## Suggested inspection (read-only) - `npm ls flowise-ui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x39m-3393-3qp4 (OSV record GHSA-x39m-3393-3qp4 lists affected ranges: npm flowise-ui >=0 <3.0.10 (fixed)) - Verified: https://github.com/advisories/GHSA-x39m-3393-3qp4 (GitHub-reviewed advisory GHSA-x39m-3393-3qp4 lists affected ranges: npm flowise-ui >=0 <3.0.10) Commands are suggestions: review each one before running it.
Loading voting…