Skip to content

← Actionable
Critical, CVSS 9.3amended

Flowise has unsandboxed remote code execution via Custom MCP

CVE-2025-71336GHSA-6933-jpx5-q87q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.0.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    >= 2.2.7-patch.1, < 3.0.6
    Fixed in
    3.0.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-71336: 1.15% estimated exploitation activity in the next 30 days; percentile 66.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Custom MCPs feature is designed to execute OS commands, for instance, using tools like `npx` to spin up local MCP Servers. However, Flowise's inherent authentication and authorization model is minimal and lacks role-based access controls (RBAC). Furthermore, the default installation of Flowise operates without authentication unless explicitly configured using the `FLOWISE_USERNAME` and `FLOWISE_PASSWORD` environment variables. This combination presents a significant security risk, potentially allowing users on the platform to execute unsandboxed system commands. This can result in Remote Code Execution (RCE) and complete compromise of the running platform container or server.

PoC 1. Follow the provided instructions for running the app using Docker Compose (or other methods of your choosing such as `npx`, `pnpm`, etc): https://github.com/FlowiseAI/Flowise?tab=readme-ov-file#-docker 2. Create a new file named `payload.json` somewhere in your machine, with the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-6933-jpx5-q87q

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-6933-jpx5-q87q

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-6933-jpx5-q87q

  4. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  5. Revision 1 · created ·

    Published from osv record GHSA-6933-jpx5-q87q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-71336

Advisory: Flowise has unsandboxed remote code execution via Custom MCP
IDs: CVE-2025-71336, GHSA-6933-jpx5-q87q
Record: https://patchnext.com/advisories/cve-2025-71336 (revision 5, source checked 4 Nov 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.0.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected >= 2.2.7-patch.1, < 3.0.6; fixed in 3.0.6

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6933-jpx5-q87q (OSV record GHSA-6933-jpx5-q87q lists affected ranges: npm flowise >=2.2.7-patch.1 <3.0.6 (fixed))
- Verified: https://github.com/advisories/GHSA-6933-jpx5-q87q (GitHub-reviewed advisory GHSA-6933-jpx5-q87q lists affected ranges: npm flowise >=2.2.7-patch.1 <3.0.6)

Commands are suggestions: review each one before running it.

Loading voting…