Skip to content

← Actionable
Critical, CVSS 9.3amended

Flowise has arbitrary file access due to missing chat flow id validation

CVE-2025-71334GHSA-q67q-549q-p849

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.0.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    >= 2.2.8, < 3.0.6
    Fixed in
    3.0.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-71334: 4.36% estimated exploitation activity in the next 30 days; percentile 91.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Missing chat flow id validation allows an attacker to access arbitrary file.

Details Commit https://github.com/FlowiseAI/Flowise/commit/8bd3de41533de78e4ef6c980e5704a1f9cb7ae6f and https://github.com/FlowiseAI/Flowise/commit/c2b830f279e454e8b758da441016b2234f220ac7 added check for `filename` when handling file upload operations to prevent path traversal, and additional validation of `chatflowId` and `chatId` from route `/api/v1/attachments`. In some cases, however, `chatflowId` and `chatId` are not validated to ensure they are UUIDs or numbers, which may lead to security issues. Case 1 When creating new chatflow via `/api/v1/chatflows`, function `addBase64FilesToStorage` is called if there exists base64 file data. Although the `filename` is sanitized, the `chatflowid` comes from request body directly without any validation. An attacker could exploit the path traversal here to write arbitrary file with controlled data. ```typescript export const…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-q67q-549q-p849

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-q67q-549q-p849

  3. Revision 2 · amended ·

    Amended from ghsa record GHSA-q67q-549q-p849

  4. Revision 1 · created ·

    Published from osv record GHSA-q67q-549q-p849

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-71334

Advisory: Flowise has arbitrary file access due to missing chat flow id validation
IDs: CVE-2025-71334, GHSA-q67q-549q-p849
Record: https://patchnext.com/advisories/cve-2025-71334 (revision 4, source checked 4 Nov 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.0.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected >= 2.2.8, < 3.0.6; fixed in 3.0.6

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q67q-549q-p849 (OSV record GHSA-q67q-549q-p849 lists affected ranges: npm flowise >=2.2.8 <3.0.6 (fixed))
- Verified: https://github.com/advisories/GHSA-q67q-549q-p849 (GitHub-reviewed advisory GHSA-q67q-549q-p849 lists affected ranges: npm flowise >=2.2.8 <3.0.6)

Commands are suggestions: review each one before running it.

Loading voting…