Skip to content

← Actionable
High, CVSS 8.3amended

Flowise does not Prevent Bypass of Password Confirmation - Unverified Password Change

CVE-2025-71328GHSA-fjh6-8679-9pch

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-ui 3.0.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2025-71328: 0.47% estimated exploitation activity in the next 30 days; percentile 40.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Bypass of Password Confirmation - Unverified Password Change (authenticated change without current password) An authenticated user is allowed to change their account password without supplying the current password or any additional verification. The application does not verify the actor’s authority to perform that credential change (no current-password check, no authorization enforcement). An attacker who is merely authenticated (or who can trick or coerce an authenticated session) can set a new password and gain control of the account. (ATO - Account Takeover) Details Occurence - code: https://github.com/FlowiseAI/Flowise/blob/main/packages/ui/src/views/account/index.jsx#L278 Remote and physical scenarios can be considered. PoC Repro steps: 1. As logged in user https://cloud.flowiseai.com/account scroll down to 'Security' section 2. Change password to the new password 3. Notice Unverified Password Change (authenticated change without current password) POC: Password changed,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fjh6-8679-9pch

  2. Revision 1 · created ·

    Published from osv record GHSA-fjh6-8679-9pch

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-71328

Advisory: Flowise does not Prevent Bypass of Password Confirmation - Unverified Password Change
IDs: CVE-2025-71328, GHSA-fjh6-8679-9pch
Record: https://patchnext.com/advisories/cve-2025-71328 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise-ui 3.0.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise-ui: affected < 3.0.10; fixed in 3.0.10

## Suggested inspection (read-only)
- `npm ls flowise-ui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fjh6-8679-9pch (OSV record GHSA-fjh6-8679-9pch lists affected ranges: npm flowise-ui >=0 <3.0.10 (fixed))
- Verified: https://github.com/advisories/GHSA-fjh6-8679-9pch (GitHub-reviewed advisory GHSA-fjh6-8679-9pch lists affected ranges: npm flowise-ui >=0 <3.0.10)

Commands are suggestions: review each one before running it.

Loading voting…