Flowise has an Arbitrary File Read
CVE-2025-71324GHSA-99pg-hqvx-r4gf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm flowise
- Affected
- >= 3.0.5, <= 3.0.5
- Fixed in
- 3.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-99pg-hqvx-r4gf lists affected ranges: npm flowise >=3.0.5 <3.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-99pg-hqvx-r4gf lists affected ranges: npm flowise >=3.0.5 <=3.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- EPSS
- CVE-2025-71324: 1.57% estimated exploitation activity in the next 30 days; percentile 75.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An arbitrary file read vulnerability in the chatId parameter supplied to both the /api/v1/get-upload-file and /api/v1/openai-assistants-file/download endpoints allows unauthenticated users to read unintended files on the local filesystem. In the default Flowise configuration this allows reading of the local sqlite db and subsequent compromise of all database content. Details Both the /api/v1/get-upload-file and /api/v1/openai-assistants-file/download endpoints accept the chatId parameter and pass this to a subsequent call to streamStorageFile(). While streamStorageFile validates that the chatflowId is a UUID and strips traversal sequences from fileName, it performs no validation of chatId. There is validation that the resulting filePath is restricted to the /root/.flowise/storage directory. However, if the file is not found in the specified path, the orgId value is removed from the filePath and reattempted. As this fallback path is read after the /root/.flowise/storage check,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-99pg-hqvx-r4gf
- Revision 1 · created ·
Published from osv record GHSA-99pg-hqvx-r4gf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-71324 Advisory: Flowise has an Arbitrary File Read IDs: CVE-2025-71324, GHSA-99pg-hqvx-r4gf Record: https://patchnext.com/advisories/cve-2025-71324 (revision 2, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise 3.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise: affected >= 3.0.5, <= 3.0.5; fixed in 3.0.6 ## Suggested inspection (read-only) - `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-99pg-hqvx-r4gf (OSV record GHSA-99pg-hqvx-r4gf lists affected ranges: npm flowise >=3.0.5 <3.0.6 (fixed)) - Verified: https://github.com/advisories/GHSA-99pg-hqvx-r4gf (GitHub-reviewed advisory GHSA-99pg-hqvx-r4gf lists affected ranges: npm flowise >=3.0.5 <=3.0.5) Commands are suggestions: review each one before running it.
Loading voting…