Skip to content

← Actionable
High, CVSS 8.9amended

Picklescan has Incomplete List of Disallowed Inputs

CVE-2025-71320GHSA-84r2-jw7c-4r5q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (picklescan 0.0.33), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-71320: 0.82% estimated exploitation activity in the next 30 days; percentile 57.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Currently picklescanner only blocks some specific functions of the pydoc and operator modules. Attackers can use other functions within these allowed modules to go through undetected and achieve RCE on the final user. Particularly pydoc.locate: Can dynamically resolve and import arbitrary modules (e.g., resolving the string "os" to the actual os module). operator.methodcaller: Allows executing a method on an object. When combined with a resolved module object, it can execute functions like system. Since locate and methodcaller are not explicitly listed in the deny-list, picklescan treats them as "Safe" or "Suspicious" (depending on configuration) but does not flag them as "Dangerous", allowing the malicious file to bypass the security check. PoC use the provided script to create a malicious pickle file The generated payload will not be flagged as dangerous by picklescan but is actually malicious. Script to open the pickle file, demonstrating impact <img width="746"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-84r2-jw7c-4r5q

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-84r2-jw7c-4r5q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-71320

Advisory: Picklescan has Incomplete List of Disallowed Inputs
IDs: CVE-2025-71320, GHSA-84r2-jw7c-4r5q
Record: https://patchnext.com/advisories/cve-2025-71320 (revision 3, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: picklescan 0.0.33. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI picklescan: affected < 0.0.33; fixed in 0.0.33

## Suggested inspection (read-only)
- `python -m pip show picklescan`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on picklescan.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-84r2-jw7c-4r5q (OSV record GHSA-84r2-jw7c-4r5q lists affected ranges: PyPI picklescan >=0 <0.0.33 (fixed))
- Verified: https://github.com/advisories/GHSA-84r2-jw7c-4r5q (GitHub-reviewed advisory GHSA-84r2-jw7c-4r5q lists affected ranges: PyPI picklescan >=0 <0.0.33)

Commands are suggestions: review each one before running it.

Loading voting…