Skip to content

← Actionable
High, CVSS 8.6

Harvester's SUSE Virtualization Registration Client Vulnerable to MITM and DOS

CVE-2025-71261GHSA-pgh9-mpwc-8jjf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/harvester/harvester 1.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
EPSS
  • CVE-2025-71261: 0.21% estimated exploitation activity in the next 30 days; percentile 10.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability has been identified in the SUSE Virtualization (Harvester) Rancher integration mechanism where by default the registration client uses an insecure TLS option that fails to verify the remote server’s certificate. This security gap could allow the execution of a man-in-the-middle (MitM) attack against SUSE Virtualization. An attacker with network-level access between the SUSE Virtualization and Rancher Manager could interfere with the TLS handshake and abuse it to bypass TLS as a security control. The registration client could be misled to send cluster registration requests to an impersonated remote service. Additionally, because the system processes response payloads without performing size validation, an attacker could induce a memory buffer overflow, leading to a potential crash of the SUSE Virtualization registration controller. Note that this vulnerability only affects the cluster registration configuration (the cluster-registration-url setting) which is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pgh9-mpwc-8jjf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-71261

Advisory: Harvester's SUSE Virtualization Registration Client Vulnerable to MITM and DOS
IDs: CVE-2025-71261, GHSA-pgh9-mpwc-8jjf
Record: https://patchnext.com/advisories/cve-2025-71261 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/harvester/harvester 1.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/harvester/harvester: affected < 1.8.0; fixed in 1.8.0

## Suggested inspection (read-only)
- Go github.com/harvester/harvester: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/harvester/harvester.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pgh9-mpwc-8jjf (GitHub-reviewed advisory GHSA-pgh9-mpwc-8jjf lists affected ranges: Go github.com/harvester/harvester >=0 <1.8.0)

Commands are suggestions: review each one before running it.

Loading voting…