Skip to content

← Actionable
Medium, CVSS 5.5amended

ajv has ReDoS when using $data option

CVE-2025-69873GHSA-2g4f-4pwh-qvx6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ajv 8.18.0, 6.14.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ajv

    Affected
    >= 7.0.0-alpha.0, < 8.18.0< 6.14.0
    Fixed in
    6.14.0, 8.18.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-69873: 0.55% estimated exploitation activity in the next 30 days; percentile 45.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ajv (Another JSON Schema Validator) through version 8.17.1 is vulnerable to Regular Expression Denial of Service (ReDoS) when the $data option is enabled. The pattern keyword accepts runtime data via JSON Pointer syntax ($data reference), which is passed directly to the JavaScript RegExp() constructor without validation. An attacker can inject a malicious regex pattern (e.g., \"^(a|a)$\") combined with crafted input to cause catastrophic backtracking. A 31-character payload causes approximately 44 seconds of CPU blocking, with each additional character doubling execution time. This enables complete denial of service with a single HTTP request against any API using ajv with $data: true for dynamic schema validation.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2g4f-4pwh-qvx6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2g4f-4pwh-qvx6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-69873

Advisory: ajv has ReDoS when using `$data` option
IDs: CVE-2025-69873, GHSA-2g4f-4pwh-qvx6
Record: https://patchnext.com/advisories/cve-2025-69873 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ajv 8.18.0, 6.14.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ajv: affected >= 7.0.0-alpha.0, < 8.18.0; < 6.14.0; fixed in 6.14.0, 8.18.0

## Suggested inspection (read-only)
- `npm ls ajv --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ajv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2g4f-4pwh-qvx6 (OSV record GHSA-2g4f-4pwh-qvx6 lists affected ranges: npm ajv >=7.0.0-alpha.0 =0 <6.14.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2g4f-4pwh-qvx6 (GitHub-reviewed advisory GHSA-2g4f-4pwh-qvx6 lists affected ranges: npm ajv >=7.0.0-alpha.0 =0 <6.14.0)

Commands are suggestions: review each one before running it.

Loading voting…