Skip to content

← Actionable
Medium, CVSS 5.4amended

BSV Blockchain SDK has an Authentication Signature Data Preparation Vulnerability

CVE-2025-69287GHSA-vjpq-xx5g-qvmm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@bsv/sdk 2.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @bsv/sdk

    Affected
    < 2.0.0
    Fixed in
    2.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
EPSS
  • CVE-2025-69287: 0.34% estimated exploitation activity in the next 30 days; percentile 27.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

BRC-104 Authentication Signature Data Preparation Vulnerability Summary A critical cryptographic vulnerability in the TypeScript SDK's BRC-104 authentication implementation caused incorrect signature data preparation, resulting in signature incompatibility between SDK implementations and potential authentication bypass scenarios. Details The vulnerability was located in the Peer.ts file of the TypeScript SDK, specifically in the processInitialRequest and processInitialResponse methods where signature data is prepared for BRC-104 mutual authentication. Vulnerable Code Locations: - ts-sdk/src/auth/Peer.ts lines 527-531 (signing) - ts-sdk/src/auth/Peer.ts lines 584-590 (verification) Root Cause: The TypeScript SDK incorrectly prepared signature data by: 1. Concatenating base64-encoded nonce strings: message.initialNonce + sessionNonce 2. Then decoding the concatenated base64 string: base64ToBytes(concatenatedString) This produced ~32-34 bytes of signature data instead of the correct 64…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vjpq-xx5g-qvmm

  2. Revision 1 · created ·

    Published from osv record GHSA-vjpq-xx5g-qvmm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-69287

Advisory: BSV Blockchain SDK has an Authentication Signature Data Preparation Vulnerability
IDs: CVE-2025-69287, GHSA-vjpq-xx5g-qvmm
Record: https://patchnext.com/advisories/cve-2025-69287 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @bsv/sdk 2.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @bsv/sdk: affected < 2.0.0; fixed in 2.0.0

## Suggested inspection (read-only)
- `npm ls @bsv/sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @bsv/sdk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vjpq-xx5g-qvmm (OSV record GHSA-vjpq-xx5g-qvmm lists affected ranges: npm @bsv/sdk >=0 <2.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vjpq-xx5g-qvmm (GitHub-reviewed advisory GHSA-vjpq-xx5g-qvmm lists affected ranges: npm @bsv/sdk >=0 <2.0.0)

Commands are suggestions: review each one before running it.

Loading voting…