pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default"
CVE-2025-69264GHSA-379q-355j-w6rj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 10.26.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pnpm
- Affected
- >= 10.0.0, < 10.26.0
- Fixed in
- 10.26.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-379q-355j-w6rj lists affected ranges: npm pnpm >=10.0.0 <10.26.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-379q-355j-w6rj lists affected ranges: npm pnpm >=10.0.0 <10.26.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-69264: 1.01% estimated exploitation activity in the next 30 days; percentile 63.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
pnpm v10+ Git Dependency Script Execution Bypass Summary A security bypass vulnerability in pnpm v10+ allows git-hosted dependencies to execute arbitrary code during pnpm install, circumventing the v10 security feature "Dependency lifecycle scripts execution disabled by default". While pnpm v10 blocks postinstall scripts via the onlyBuiltDependencies mechanism, git dependencies can still execute prepare, prepublish, and prepack scripts during the fetch phase, enabling remote code execution without user consent or approval. Details pnpm v10 introduced a security feature to disable dependency lifecycle scripts by default (PR #8897). This is implemented by setting onlyBuiltDependencies = [] when no build policy is configured: File: pkg-manager/core/src/install/extendInstallOptions.ts (lines 290-291) This creates an allowlist that blocks all packages from running scripts during the BUILD phase in exec/build-modules/src/index.ts. However, git-hosted dependencies are processed differently.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-379q-355j-w6rj
- Revision 1 · created ·
Published from osv record GHSA-379q-355j-w6rj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-69264 Advisory: pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" IDs: CVE-2025-69264, GHSA-379q-355j-w6rj Record: https://patchnext.com/advisories/cve-2025-69264 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pnpm 10.26.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pnpm: affected >= 10.0.0, < 10.26.0; fixed in 10.26.0 ## Suggested inspection (read-only) - `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pnpm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-379q-355j-w6rj (OSV record GHSA-379q-355j-w6rj lists affected ranges: npm pnpm >=10.0.0 <10.26.0 (fixed)) - Verified: https://github.com/advisories/GHSA-379q-355j-w6rj (GitHub-reviewed advisory GHSA-379q-355j-w6rj lists affected ranges: npm pnpm >=10.0.0 <10.26.0) Commands are suggestions: review each one before running it.
Loading voting…